ElementsSelectService
Canonical path: NemAll_Python_BaseElements.ElementsSelectService
Methods:
-
SelectAllElements
–Select all elements from the document
-
SelectElementsByIfcGuid
–Select elements by IFC guids
SelectAllElements
staticmethod
SelectAllElements(ele: DocumentAdapter) -> BaseElementAdapterList
Select all elements from the document
Parameters:
-
doc
–Document
Returns:
-
BaseElementAdapterList
–All elements from the document
SelectElementsByIfcGuid
staticmethod
SelectElementsByIfcGuid(ele: list) -> BaseElementAdapterList
Select elements by IFC guids
Parameters:
-
doc
–Document
-
ifcGuids
–List with the IFC GUIDs
Returns:
-
BaseElementAdapterList
–Elements
Placeholder