FaceSelectService
Canonical path: NemAll_Python_BaseElements.FaceSelectService
SelectPolyhedronFace
staticmethod
SelectPolyhedronFace(
polyhedron: BaseElementAdapter,
pnt: Point2D,
highlightFace: bool,
viewProj: ViewWorldProjection,
doc: DocumentAdapter,
includeUVSSelection: bool,
) -> tuple[bool, Polygon3D, IntersectionRayPolyhedron]
Select a polyhedron face
Parameters:
-
polyhedron
(BaseElementAdapter
) –Polyhedron
-
pnt
(Point2D
) –Selection view point
-
highlightFace
(bool
) –Highlight the face state
-
viewProj
(ViewWorldProjection
) –View world projection of the selected view
-
doc
(DocumentAdapter
) –Document
-
includeUVSSelection
(bool
) –Include an UVS selection for the face
Returns:
-
tuple[bool, Polygon3D, IntersectionRayPolyhedron]
–select state, face polygon, intersection result
SelectPolyhedronFaceInUVS
staticmethod
SelectPolyhedronFaceInUVS(
polyhedron: BaseElementAdapter,
pnt: Point2D,
highlightFace: bool,
viewProj: ViewWorldProjection,
doc: DocumentAdapter,
) -> tuple[bool, Polygon3D, IntersectionRayPolyhedron, Matrix3D]
Select a polyhedron face in an UVS
Parameters:
-
polyhedron
(BaseElementAdapter
) –Polyhedron
-
pnt
(Point2D
) –Selection view point
-
highlightFace
(bool
) –Highlight the face state
-
viewProj
(ViewWorldProjection
) –View world projection of the selected view
-
doc
(DocumentAdapter
) –Document
Returns:
-
tuple[bool, Polygon3D, IntersectionRayPolyhedron, Matrix3D]
–select state, face polygon, intersection result, UVS matrix
SelectWallFace
staticmethod
SelectWallFace(
wallTier: BaseElementAdapter,
pnt: Point2D,
highlightFace: bool,
viewProj: ViewWorldProjection,
doc: DocumentAdapter,
includeUVSSelection: bool,
) -> tuple[bool, Polygon3D, IntersectionRayPolyhedron]
Select a wall face
Parameters:
-
wallTier
(BaseElementAdapter
) –Wall tier
-
pnt
(Point2D
) –Selection view point
-
highlightFace
(bool
) –Highlight the face state
-
viewProj
(ViewWorldProjection
) –View world projection of the selected view
-
doc
(DocumentAdapter
) –Document
-
includeUVSSelection
(bool
) –Include an UVS selection for the face
Returns:
-
tuple[bool, Polygon3D, IntersectionRayPolyhedron]
–select state, face polygon, intersection result
SelectWallFaceInUVS
staticmethod
SelectWallFaceInUVS(
wallTier: BaseElementAdapter,
pnt: Point2D,
highlightFace: bool,
viewProj: ViewWorldProjection,
doc: DocumentAdapter,
) -> tuple[bool, Polygon3D, IntersectionRayPolyhedron, Matrix3D]
Select a wall face in an UVS
Parameters:
-
wallTier
(BaseElementAdapter
) –Wall tier
-
pnt
(Point2D
) –Selection view point
-
highlightFace
(bool
) –Highlight the face state
-
viewProj
(ViewWorldProjection
) –View world projection of the selected view
-
doc
(DocumentAdapter
) –Document
Returns:
-
tuple[bool, Polygon3D, IntersectionRayPolyhedron, Matrix3D]
–select state, face polygon, intersection result, UVS matrix