ZoomService
Canonical path: NemAll_Python_BaseElements.ZoomService
Implementation of the zoom service
ZoomToElement
ZoomToElement(
element: BaseElementAdapter,
viewProj: ViewWorldProjection,
inflateValue: float,
bZoomAll: bool,
)
Zoom to the element
Parameters:
-
element
(BaseElementAdapter
) –Element
-
viewProj
(ViewWorldProjection
) –View world projection
-
inflateValue
(float
) –Inflate value for the min/max box
-
bZoomAll
(bool
) –Zoom in all views state
ZoomToElementWithFactor
ZoomToElementWithFactor(
element: BaseElementAdapter,
viewProj: ViewWorldProjection,
factor: float,
bZoomAll: bool,
)
Zoom to the element
Parameters:
-
element
(BaseElementAdapter
) –Element
-
viewProj
(ViewWorldProjection
) –View world projection
-
factor
(float
) –Factor for zooming, 0.5 means 50% zooming
-
bZoomAll
(bool
) –Zoom in all views state
ZoomToElements
ZoomToElements(
elements: BaseElementAdapterList,
viewProj: ViewWorldProjection,
inflateValue: float,
bZoomAll: bool,
)
Zoom to the elements
Parameters:
-
elements
(BaseElementAdapterList
) –Elements
-
viewProj
(ViewWorldProjection
) –View world projection
-
inflateValue
(float
) –Inflate value for the min/max box
-
bZoomAll
(bool
) –Zoom in all views state
ZoomToElementsWithFactor
ZoomToElementsWithFactor(
elements: BaseElementAdapterList,
viewProj: ViewWorldProjection,
factor: float,
bZoomAll: bool,
)
Zoom to the elements
Parameters:
-
elements
(BaseElementAdapterList
) –Elements
-
viewProj
(ViewWorldProjection
) –View world projection
-
factor
(float
) –Factor for zooming, 0.5 means 50% zooming
-
bZoomAll
(bool
) –Zoom in all views state
ZoomToMinMaxBox
overloaded
ZoomToMinMaxBox(
minMaxBox: MinMax3D,
viewProj: ViewWorldProjection,
inflateValue: float,
bZoomAll: bool,
)
Zoom to the min/max box
Parameters:
-
minMaxBox
(MinMax3D
) –Zoom area
-
viewProj
(ViewWorldProjection
) –View world projection
-
inflateValue
(float
) –Inflate value for the min/max box
-
bZoomAll
(bool
) –Zoom in all views state
ZoomToMinMaxBox(
minMaxBox: MinMax3D,
viewProj: ViewWorldProjection,
inflateValueX: float,
inflateValueY: float,
inflateValueZ: float,
bZoomAll: bool,
)
Zoom to the min/max box
Parameters:
-
minMaxBox
(MinMax3D
) –Zoom area
-
viewProj
(ViewWorldProjection
) –View world projection
-
inflateValueX
(float
) –Inflate value for the min/max box in x direction
-
inflateValueY
(float
) –Inflate value for the min/max box in y direction
-
inflateValueZ
(float
) –Inflate value for the min/max box in z direction
-
bZoomAll
(bool
) –Zoom in all views state
ZoomToMinMaxBoxWithFactor
ZoomToMinMaxBoxWithFactor(
minMaxBox: MinMax3D,
viewProj: ViewWorldProjection,
factor: float,
bZoomAll: bool,
)
Zoom to the min/max box
Parameters:
-
minMaxBox
(MinMax3D
) –Zoom area
-
viewProj
(ViewWorldProjection
) –View world projection
-
factor
(float
) –Factor for zooming, 0.5 means 50% zooming
-
bZoomAll
(bool
) –Zoom in all views state