BitmapAreaElement
Canonical path: NemAll_Python_BasisElements.BitmapAreaElement
Bases: BasisElement
, AllplanElement
Representation of the bitmap area in Allplan.
GetBitmapAreaProperties
GetBitmapAreaProperties() -> BitmapAreaProperties
SetBitmapAreaProperties
SetBitmapAreaProperties(bitmapAreaProp: BitmapAreaProperties)
Set the bitmapArea properties
Parameters:
-
bitmapAreaProp
(BitmapAreaProperties
) –BitmapArea properties
__init__
overloaded
Initialize
__init__(
commonProp: CommonProperties,
bitmapAreaProp: BitmapAreaProperties,
geometryObject: object,
)
Constructor
Parameters:
-
commonProp
(CommonProperties
) –Common properties
-
bitmapAreaProp
(BitmapAreaProperties
) –BitmapArea properties
-
geometryObject
(object
) –Geometry element
__init__(BitmapAreaElement: BitmapAreaElement)
Copy constructor
Parameters:
-
bitmpaAreaElement
–Bitmap area element element to copy
Placeholder