ClippingPathProperties
Canonical path: NemAll_Python_BasisElements.ClippingPathProperties
Representation if the properties of a clipping path of a UVS
Classes:
-
SectionType_Enum
–Section type
Methods:
-
__init__
–Initialize
Attributes:
-
BottomLevel
(None
) –The bottom elevation of the section
-
IsClippingLineOn
(None
) –Whether to draw the clipping line
-
IsHeightFromElementOn
(None
) –Whether to get the section height from elements
-
SectionIdentifier
(None
) –the section identifier
-
SectionType
(None
) –Property for type of section
-
TopLevel
(None
) –The top elevation of the section
IsHeightFromElementOn
property
Whether to get the section height from elements
SectionType_Enum
Canonical path: NemAll_Python_BasisElements.ClippingPathProperties.SectionType_Enum
Bases: Enum
Section type
Methods:
-
__getitem__
–get the item for a key
__getitem__
__getitem__(key: str | int | float) -> SectionType_Enum
get the item for a key
Parameters:
-
key
(str | int | float
) –value key
Returns:
-
SectionType_Enum
–value for the key
Placeholder