DimensionProperties
Canonical path: NemAll_Python_BasisElements.DimensionProperties
Properties of the dimension line as well as the elevation points.
Methods:
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
ElevationBaseOffset
(None
) –Property for the elevation base offset
-
FontIDDimensionNumber
(None
) –Property for the font ID of the dimension number
-
IsAbsoluteElevation
(None
) –Whether to use the absolute elevation values
-
LeadingCharacter
(None
) –Property for the leading characters
-
PointSymbol
(None
) –Property for the point symbol of the elevation
-
PointSymbolEnd
(None
) –Property for the point symbol at the start of the dimension line
-
PointSymbolStart
(None
) –Property for the point symbol at the start of the dimension line
-
TailingCharacters
(None
) –Property for the tailing characters
-
TextHeightDimensionNumber
(None
) –Property for the height of the dimension number
-
TextLocation
(None
) –The location of the dimension number
-
TextOffset
(None
) –Offset of text from dimension line
ElevationBaseOffset
property
Property for the elevation base offset
:type: None
FontIDDimensionNumber
property
Property for the font ID of the dimension number
:type: None
PointSymbolEnd
property
Property for the point symbol at the start of the dimension line
:type: None
PointSymbolStart
property
Property for the point symbol at the start of the dimension line
:type: None
TextHeightDimensionNumber
property
Property for the height of the dimension number
:type: None
__init__
overloaded
Initialize
__init__(arg2: DocumentAdapter, arg3: Dimensioning)
Default constructor
__init__(arg2: DimensionProperties)
Constructor