ModelElement2D
Canonical path: NemAll_Python_BasisElements.ModelElement2D
Bases: BasisElement
, AllplanElement
Representation of a general two-dimensional model element, such as line, arc or polyline.
Methods:
-
GetEndSymbolsProperties
–Get the end symbols properties
-
GetPatternCurveProperties
–Get the pattern curve properties
-
GetTransformationList
–Get transformation list
-
SetEndSymbolsProperties
–Set the end symbols properties
-
SetPatternCurveProperties
–Set the pattern curve properties
-
SetTransformationList
–Set the transformation list
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
EndSymbolsProperties
(EndSymbolsProperties
) –Get the end symbols properties
-
PatternCurveProperties
(PatternCurveProperties
) –Get the pattern curve properties
-
TransformationList
(list
) –Get transformation list
EndSymbolsProperties
property
writable
EndSymbolsProperties: EndSymbolsProperties
Get the end symbols properties
PatternCurveProperties
property
writable
PatternCurveProperties: PatternCurveProperties
Get the pattern curve properties
GetEndSymbolsProperties
GetEndSymbolsProperties() -> EndSymbolsProperties
GetPatternCurveProperties
GetPatternCurveProperties() -> PatternCurveProperties
GetTransformationList
Get transformation list
Returns:
-
list
–List with the transformations
SetEndSymbolsProperties
SetEndSymbolsProperties(endSymbolsProp: EndSymbolsProperties)
Set the end symbols properties
Parameters:
-
endSymbolsProp
(EndSymbolsProperties
) –End symbols properties
SetPatternCurveProperties
SetPatternCurveProperties(patternCurveProp: PatternCurveProperties)
Set the pattern curve properties
Parameters:
-
patternCurveProp
(PatternCurveProperties
) –Pattern curve properties
SetTransformationList
Set the transformation list
Parameters:
-
transformationList
(list
) –List with the transformations
__init__
overloaded
Initialize
__init__(commonProp: CommonProperties, geometryObject: object)
Constructor
Parameters:
-
commonProp
(CommonProperties
) –Common properties
-
geometryObject
(object
) –Geometry element
__init__(
commonProp: CommonProperties,
patternCurveProp: PatternCurveProperties,
endSymbolProp: EndSymbolsProperties,
geometryObject: object,
)
Constructor
Parameters:
-
commonProp
(CommonProperties
) –Common properties
-
patternCurveProp
(PatternCurveProperties
) –End symbols properties
-
endSymbolProp
(EndSymbolsProperties
) –Pattern curve properties
-
geometryObject
(object
) –Geometry element
__init__(element: ModelElement2D)