PatternProperties
Canonical path: NemAll_Python_BasisElements.PatternProperties
Properties of the pattern
Methods:
-
SetBackgroundColorBGR
–Set the background color
-
SetBackgroundColorIRGB
–Set the background color
-
__eq__
–equal operator
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
BackgroundColor
(ARGB
) –Background color. Relevant if UseBackgroundColor is set to True
-
IsScaleDependent
(bool
) –Whether the pattern is to be scale dependent
-
PatternID
(int
) –Get the pattern ID
-
PlacementType
(PlacementType
) –Placing mode
-
ReferencePoint
(Point2D
) –reference point. Relevant if UseReferencePoint is set to True.
-
RotationAngle
(Angle
) –Rotation angle
-
UseBackgroundColor
(bool
) –Whether to use a background color in the pattern
-
UseReferencePoint
(bool
) –Whether to use the reference point from ReferencePoint property for the pattern origin
-
XScalingFactor
(float
) –Get the scaling factor in x direction
-
YScalingFactor
(float
) –Get the scaling factor in y direction
BackgroundColor
property
writable
BackgroundColor: ARGB
Background color. Relevant if UseBackgroundColor is set to True
IsScaleDependent
property
writable
Whether the pattern is to be scale dependent
ReferencePoint
property
writable
ReferencePoint: Point2D
reference point. Relevant if UseReferencePoint is set to True.
UseBackgroundColor
property
writable
Whether to use a background color in the pattern
UseReferencePoint
property
writable
Whether to use the reference point from ReferencePoint property for the pattern origin
SetBackgroundColorBGR
Set the background color
Parameters:
-
value
(int
) –Color value as BGR
SetBackgroundColorIRGB
Set the background color
Parameters:
-
value
(int
) –Color value as IRGB
__eq__
__eq__(prop: PatternProperties) -> bool
equal operator
Parameters:
-
prop
(PatternProperties
) –PatternProperties to compare
Returns:
-
bool
–true if they are equal, false otherwise