SectionAlongPathClippingPathProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathClippingPathProperties
Clipping path properties
Methods:
-
GetClippingPathGeometryTolerance
–Access tolerances
-
GetPathLength
–Get length of path
-
GetResultPathLength
–Get length of the part of path limited by EndCoord and StartCoord
-
RestrictEmptySectionId
– -
__init__
–Overloaded function. See individual overloads.
Attributes:
-
BottomLevel
(float
) –Get the BottomLevel for section Vertical or Horizontal_From_Top
-
ClippingPathViewProperties
(SectionAlongPathClippingPathViewProperties
) –Get the SectionAlongPathClippingPathViewProperties
-
EndCoord
(float
) –Get the EndCoord value
-
IsChangeViewDirectionOn
(bool
) –Get the IsChangeViewDirectionOn status : ON/OFF
-
IsClippingLineOn
(bool
) –Get the Is clipping path line on
-
IsHeightFromElementOn
(bool
) –Get the IsHeightFromElementOn status : ON/OFF
-
SectionIdentifier
(str
) –Get the Section identifier
-
StartCoord
(float
) –Get the StartCoord value
-
StationingEnd
(float
) –Get end stationing
-
StationingStart
(float
) –Get start stationing
-
TopLevel
(float
) –Get the TopLevel for section Vertical or Horizontal_From_Bottom
BottomLevel
property
writable
Get the BottomLevel for section Vertical or Horizontal_From_Top
ClippingPathViewProperties
property
writable
ClippingPathViewProperties: SectionAlongPathClippingPathViewProperties
Get the SectionAlongPathClippingPathViewProperties
IsChangeViewDirectionOn
property
writable
Get the IsChangeViewDirectionOn status : ON/OFF
IsHeightFromElementOn
property
writable
Get the IsHeightFromElementOn status : ON/OFF
TopLevel
property
writable
Get the TopLevel for section Vertical or Horizontal_From_Bottom
GetClippingPathGeometryTolerance
staticmethod
Access tolerances
Returns:
-
float
–ClippingPathGeometryTolerance
GetResultPathLength
Get length of the part of path limited by EndCoord and StartCoord
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathClippingPathProperties)