SectionAlongPathClippingPathViewProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathClippingPathViewProperties
Clipping path view properties
Methods:
-
ConvertDirectionSymbolNumberFromViewModel
–Convert icon number used in WPF palette to symbol number used in Allplan
-
ConvertDirectionSymbolNumberToViewModel
–Convert symbol number used in Allplan to icon number used in WPF palette
-
GetDirectionSymbolHeightTolerance
–Access tolerances
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
DirectionSymbolHeight
(float
) –Get the DirectionSymbolHeight
-
DirectionSymbolNr
(int
) –Get the DirectionSymbolNr
-
IsDirectionSymbolOn
(bool
) –Get the IsDirectionSymbolOn
-
TextParameterProperties
(SectionAlongPathTextParameterProperties
) –Access text params
TextParameterProperties
property
writable
TextParameterProperties: SectionAlongPathTextParameterProperties
Access text params
Get the SectionAlongPathTextParameterProperties
ConvertDirectionSymbolNumberFromViewModel
Convert icon number used in WPF palette to symbol number used in Allplan for the same graphical representation
Parameters:
-
iPaletteIconNum
(bool
) –number of icon from palette (view model)
ConvertDirectionSymbolNumberToViewModel
Convert symbol number used in Allplan to icon number used in WPF palette for the same graphical representation
Returns:
-
int
–icon number used in WPF
GetDirectionSymbolHeightTolerance
staticmethod
Access tolerances
Returns:
-
float
–symbol height tolerance
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathClippingPathViewProperties)