SectionAlongPathElement
Canonical path: NemAll_Python_BasisElements.SectionAlongPathElement
Bases: BasisElement
, AllplanElement
Implementation of the section along path element
__init__
overloaded
__init__(
sectionAlongPathProperties: SectionAlongPathProperties,
sectionPathElement: BaseElementAdapter,
)
Default constructor
Parameters:
-
sectionAlongPathProperties
(SectionAlongPathProperties
) –Section along path properties
-
sectionPathElement
(BaseElementAdapter
) –Section path element
__init__(
sectionAlongPathProperties: SectionAlongPathProperties,
sectionPath: Path2D,
comProp: CommonProperties,
)
Constructor
Parameters:
-
sectionAlongPathProperties
(SectionAlongPathProperties
) –Section along path properties
-
sectionPath
(Path2D
) –Section path
-
comProp
(CommonProperties
) –Common properties
__init__(element: SectionAlongPathElement)
Placeholder