SectionAlongPathElevationSpecifications
Canonical path: NemAll_Python_BasisElements.SectionAlongPathElevationSpecifications
Elevation specifications
Methods:
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
DecimalPlaces
(int
) –Get the number of places after decimal point
-
FontHeight
(float
) –Get the Height of the character set
-
FontNameStrg
(str
) –Get the Name the the character set
-
HeightWidthFactor
(float
) –Get the height/width ratio
-
IsAbsoluteElevation
(bool
) –Get the Absolute elevation
-
IsDimensionLineVisible
(bool
) –Get the visibility of dimension line
-
IsDimensionNumberVisible
(bool
) –Get the Dimension number is visible
-
IsFixFraction
(bool
) –Get the Fix fraction
-
IsFontBold
(bool
) –Get the character set Bold
-
IsFontItalic
(bool
) –Get the character set Italic
-
IsFontUnderline
(bool
) –Get the character set Underline
-
IsFreeElevation
(bool
) –Get the Free elevation
-
IsLineColorFromLayer
(bool
) –Get the settings from layers three checkboxes on third page in layer dialog like in BBasisDimSettings.h (do not know, why is it is doubled)
-
IsLineColorSameForAll
(bool
) –Get the the same line color for DMline,auxiliary line and number/texts
-
IsLineColorTake
(bool
) –Get the settings from layers three checkboxes on third page in layer dialog
-
IsModifiedIsTextOpaque
(bool
) –Get the is text opaque
-
IsPenFromLayer
(bool
) –Get the settings from layers three checkboxes on third page in layer dialog like in BasisDimSettings.h (do not know, why is it is doubled)
-
IsPenSameForAll
(bool
) –Get the the same pen for DMline,auxiliary line and number/texts
-
IsPenSymbolFlag
(bool
) –Get the when true -> pen for symbol as help construction line
-
IsPenTake
(bool
) –Get the settings from layers three checkboxes on third page in layer dialog
-
IsPlusMinusSign
(bool
) –Get the Draw +- sign before zero number
-
IsPositiveSign
(bool
) –Get the Draw +s ign before positive number
-
IsTextSymbolFlag
(bool
) –Get the when true -> pen for text as help construction line
-
LayerId
(int
) –Get the Layer Number
-
LeadingCharacters
(str
) –Get the prefix of dimension number/additional number(16)
-
MeasuredValueUnit
(int
) –Get the Unit of the measured value
-
PointSymbol
(int
) –Get the Point symbol
-
PointSymbolSize
(float
) –Get the symbol size in mm/inch
-
RoundOffInch
(float
) –Get the round of number inch units
-
RoundOffNormal
(float
) –Get the round of number metric units
-
SymbolColorId
(int
) –Get the Symbol color
-
SymbolPenId
(int
) –Get the Symbol pen
-
TailingCharacters
(str
) –Get the suffix of dimension number/additional number(16)
-
TailingZeros
(int
) –Get the number of zeros after decimal point
-
TextColorId
(int
) –Get the Text color
-
TextLocation
(int
) –Get the text location from position / location of texts (up to enum eTextLocation)
-
TextOffset
(float
) –Get the distance -> offset of texts from dimension line
-
TextPenId
(int
) –Get the Text pen
IsDimensionLineVisible
property
writable
Get the visibility of dimension line
IsDimensionNumberVisible
property
writable
Get the Dimension number is visible
IsLineColorFromLayer
property
writable
Get the settings from layers three checkboxes on third page in layer dialog like in BBasisDimSettings.h (do not know, why is it is doubled)
IsLineColorSameForAll
property
writable
Get the the same line color for DMline,auxiliary line and number/texts
IsLineColorTake
property
writable
Get the settings from layers three checkboxes on third page in layer dialog
IsPenFromLayer
property
writable
Get the settings from layers three checkboxes on third page in layer dialog like in BasisDimSettings.h (do not know, why is it is doubled)
IsPenSameForAll
property
writable
Get the the same pen for DMline,auxiliary line and number/texts
IsPenSymbolFlag
property
writable
Get the when true -> pen for symbol as help construction line
IsPenTake
property
writable
Get the settings from layers three checkboxes on third page in layer dialog
IsTextSymbolFlag
property
writable
Get the when true -> pen for text as help construction line
LeadingCharacters
property
writable
Get the prefix of dimension number/additional number(16)
TailingCharacters
property
writable
Get the suffix of dimension number/additional number(16)
TextLocation
property
writable
Get the text location from position / location of texts (up to enum eTextLocation)
TextOffset
property
writable
Get the distance -> offset of texts from dimension line
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathElevationSpecifications)