SectionAlongPathFilterProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathFilterProperties
Filter properties
Methods:
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
DrawingFilesProperties
(SectionDrawingFilesProperties
) –Access drawing file params
-
IsAssociativityOn
(bool
) –Get the When the section is frozen / associativity is OFF -, no updates are available for it
-
IsSelectionFilterOn
(bool
) –Get the when == true - only selected elements are included to UVS model / when == false (default value) - selected elements are excluded from UVS model
-
LayerProperties
(SectionLayerProperties
) –Access layer params
DrawingFilesProperties
property
writable
DrawingFilesProperties: SectionDrawingFilesProperties
Access drawing file params
Get the SectionDrawingFilesProperties
IsAssociativityOn
property
writable
Get the When the section is frozen / associativity is OFF -, no updates are available for it
IsSelectionFilterOn
property
writable
Get the when == true - only selected elements are included to UVS model / when == false (default value) - selected elements are excluded from UVS model
LayerProperties
property
writable
LayerProperties: SectionLayerProperties
Access layer params
Get the SectionLayerProperties
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathFilterProperties)