SectionAlongPathFormatProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathFormatProperties
Format properties
Methods:
-
GetEliminationAngleTolerance
–Access tolerances
-
GetOverhangTolerance
–Access tolerances
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
AdjacentEdgeTypeSwitcher
(int
) –Get the 0=material, 1=surface, we set a tooltip and description in palette
-
BoundaryLineColor
(int
) –Get the Border: Boundary Line color index
-
BoundaryLineLayer
(int
) –Get the Border: Boundary Line Layer number
-
BoundaryLineLayerKenner
(int
) –Gets layer kenner for Boundary Line
-
BoundaryLinePen
(int
) –Get the Border: Boundary Line pen index (0== not used)
-
BoundaryLineType
(int
) –Get the Border: Boundary Line stroke index
-
EdgesVisibility
(bool
) –Get the Outer edges/All edges Visible 0, 1
-
EliminationAngle
(float
) –Get the Angle of the Adjacent Edge elimination, //always in degree
-
IsBetweenDifferentSurfacesOn
(bool
) –Get the Adjacent Edge Between Different Surfaces
-
IsBoundaryLineColorFromLayer
(bool
) –Get the Border: IsBoundaryLineColorFromLayer
-
IsBoundaryLinePenFromLayer
(bool
) –Get the Border: IsBoundaryLinePenFromLayer
-
IsBoundaryLineTypeFromLayer
(bool
) –Get the Border: IsBoundaryLineTypeFromLayer
-
IsBoundaryLineVisible
(bool
) –Get the BoundaryLine visibility
-
IsEliminationOn
(bool
) –Get the Adjacent Edge elimination
-
IsSectionLineColorFromLayer
(bool
) –Get the Section: IsSectionLineColorFromLayer
-
IsSectionLinePenFromLayer
(bool
) –Get the Section: IsSectionLinePenFromLayer
-
IsSectionLineThicknessVisible
(bool
) –Get the SectionLineThickness visibility
-
IsSectionLineTypeFromLayer
(bool
) –Get the Section: IsSectionLineTypeFromLayer
-
IsSurfaceFromObjectOn
(bool
) –Get the Display Surface From Object
-
Overhang
(float
) –Get the Overhang
-
SectionLineColor
(int
) –Get the Section: Boundary Line color index
-
SectionLineLayer
(int
) –Get the Section: Section Line Layer number
-
SectionLineLayerKenner
(int
) –Gets layer kenner for Section Line
-
SectionLinePen
(int
) –Get the Section: Boundary Line pen index (0== not used)
-
SectionLineType
(int
) –Get the Section: Boundary Line stroke index
AdjacentEdgeTypeSwitcher
property
writable
Get the 0=material, 1=surface, we set a tooltip and description in palette
BoundaryLineColor
property
writable
Get the Border: Boundary Line color index
BoundaryLineLayer
property
writable
Get the Border: Boundary Line Layer number
BoundaryLineLayerKenner
property
writable
Gets layer kenner for Boundary Line
Sets layer kenner for Boundary Line
BoundaryLinePen
property
writable
Get the Border: Boundary Line pen index (0== not used)
EliminationAngle
property
writable
Get the Angle of the Adjacent Edge elimination, //always in degree
IsBetweenDifferentSurfacesOn
property
writable
Get the Adjacent Edge Between Different Surfaces
IsBoundaryLineColorFromLayer
property
writable
Get the Border: IsBoundaryLineColorFromLayer
IsBoundaryLinePenFromLayer
property
writable
Get the Border: IsBoundaryLinePenFromLayer
IsBoundaryLineTypeFromLayer
property
writable
Get the Border: IsBoundaryLineTypeFromLayer
IsSectionLineColorFromLayer
property
writable
Get the Section: IsSectionLineColorFromLayer
IsSectionLinePenFromLayer
property
writable
Get the Section: IsSectionLinePenFromLayer
IsSectionLineThicknessVisible
property
writable
Get the SectionLineThickness visibility
IsSectionLineTypeFromLayer
property
writable
Get the Section: IsSectionLineTypeFromLayer
IsSurfaceFromObjectOn
property
writable
Get the Display Surface From Object
SectionLineLayerKenner
property
writable
Gets layer kenner for Section Line
Sets layer kenner for Section Line
SectionLinePen
property
writable
Get the Section: Boundary Line pen index (0== not used)
GetEliminationAngleTolerance
staticmethod
Access tolerances
Returns:
-
float
–elimination angle tolerance
GetOverhangTolerance
staticmethod
Access tolerances
Returns:
-
float
–overhang tolerance
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathFormatProperties)