SectionAlongPathGeneralSectionProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathGeneralSectionProperties
General section properties
Methods:
-
GetOffset
–Get offset
-
IsOffsetValid
–Get offset state
-
SetOffset
–Set offset
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
ElevationSpecifications
(SectionAlongPathElevationSpecifications
) –Get the SectionAlongPathElevationSpecifications
-
FormatProperties
(SectionAlongPathFormatProperties
) –Get the SectionAlongPathFormatProperties
-
LabelingStripSetting
(SectionAlongPathLabelingStripSetting
) –Get the SectionAlongPathLabelingStripSetting
-
Offset_X
(float
) –Get the X coordinate of left bottom corner
-
Offset_Y
(float
) –Get the Y coordinate of left bottom corner
-
SectionLabelingProperties
(SectionAlongPathSectionLabelingProperties
) –Get the SectionAlongPathSectionLabelingProperties
-
SectionViewProperties
(SectionAlongPathSectionViewProperties
) –Get the SectionAlongPathSectionViewProperties
ElevationSpecifications
property
writable
ElevationSpecifications: SectionAlongPathElevationSpecifications
Get the SectionAlongPathElevationSpecifications
FormatProperties
property
writable
FormatProperties: SectionAlongPathFormatProperties
Get the SectionAlongPathFormatProperties
LabelingStripSetting
property
writable
LabelingStripSetting: SectionAlongPathLabelingStripSetting
Get the SectionAlongPathLabelingStripSetting
SectionLabelingProperties
property
writable
SectionLabelingProperties: SectionAlongPathSectionLabelingProperties
Get the SectionAlongPathSectionLabelingProperties
SectionViewProperties
property
writable
SectionViewProperties: SectionAlongPathSectionViewProperties
Get the SectionAlongPathSectionViewProperties
GetOffset
GetOffset() -> tuple[bool, float, float]
Get offset
Returns:
-
tuple[bool, float, float]
–tuple(true if it was read from 55th element, X coordinate of section's left bottom corner, Y coordinate of section's left bottom corner)
SetOffset
Set offset
Parameters:
-
dOffset_X
(float
) –X coordinate of section's left bottom corner
-
dOffset_Y
(float
) –Y coordinate of section's left bottom corner
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathGeneralSectionProperties)