SectionAlongPathProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathProperties
Section along path properties
Methods:
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
ClippingPathProperties
(SectionAlongPathClippingPathProperties
) –Get the SectionAlongPathClippingPathProperties
-
FilterProperties
(SectionAlongPathFilterProperties
) –Get the SectionAlongPathFilterProperties
-
GeneralSectionProperties
(SectionAlongPathGeneralSectionProperties
) –Get the SectionAlongPathGeneralSectionProperties
-
ScaleProperties
(SectionAlongPathScaleProperties
) –Get the SectionAlongPathScaleProperties
ClippingPathProperties
property
writable
ClippingPathProperties: SectionAlongPathClippingPathProperties
Get the SectionAlongPathClippingPathProperties
FilterProperties
property
writable
FilterProperties: SectionAlongPathFilterProperties
Get the SectionAlongPathFilterProperties
GeneralSectionProperties
property
writable
GeneralSectionProperties: SectionAlongPathGeneralSectionProperties
Get the SectionAlongPathGeneralSectionProperties
ScaleProperties
property
writable
ScaleProperties: SectionAlongPathScaleProperties
Get the SectionAlongPathScaleProperties
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathProperties)
Placeholder