SectionAlongPathSectionLabelingProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathSectionLabelingProperties
Section labeling properties
Classes:
-
SAAPLabelingPosition_Enum
–enum for Reference point position
Methods:
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
HeadingText
(str
) –Get the HeadingText "longitudinal profile", "transversal profile", "elevation", "section", "Unfold", . and "none" (expandable)
-
HeadingTextParameters
(SectionAlongPathTextParameterProperties
) –Get the SectionAlongPathTextParameterProperties
-
IsHeadingOn
(bool
) –Get the IsHeadingOn
-
IsScaleOn
(bool
) –Get the IsScaleOn
-
LabelingOffset
(float
) –Get the Distance of the labeling from its content's min/max box
-
LabelingPosition
(int
) –Get the Position of the labeling with respect to its content's min/max box
-
LabelingsDistance
(float
) –Get the Distance between scale text and heading text
-
ScaleTextParameters
(SectionAlongPathTextParameterProperties
) –Get the SectionAlongPathTextParameterProperties
HeadingText
property
writable
Get the HeadingText "longitudinal profile", "transversal profile", "elevation", "section", "Unfold", . and "none" (expandable)
HeadingTextParameters
property
writable
HeadingTextParameters: SectionAlongPathTextParameterProperties
Get the SectionAlongPathTextParameterProperties
LabelingOffset
property
writable
Get the Distance of the labeling from its content's min/max box
LabelingPosition
property
writable
Get the Position of the labeling with respect to its content's min/max box
LabelingsDistance
property
writable
Get the Distance between scale text and heading text
ScaleTextParameters
property
writable
ScaleTextParameters: SectionAlongPathTextParameterProperties
Get the SectionAlongPathTextParameterProperties
SAAPLabelingPosition_Enum
Canonical path: NemAll_Python_BasisElements.SectionAlongPathSectionLabelingProperties.SAAPLabelingPosition_Enum
Bases: Enum
enum for Reference point position
Nothing: Calculated like before this implementation
Methods:
-
__getitem__
–get the item for a key
__getitem__
__getitem__(key: str | int | float) -> SAAPLabelingPosition_Enum
get the item for a key
Parameters:
-
key
(str | int | float
) –value key
Returns:
-
SAAPLabelingPosition_Enum
–value for the key
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathSectionLabelingProperties)