SectionAlongPathSectionViewProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathSectionViewProperties
Section view properties
Methods:
-
GetHorizontTolerance
–Access tolerances
-
GetOffsetTolerance
–Access tolerances
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
Horizont
(float
) –Get the Horizon
-
IsElementedgesDisplayed
(bool
) –Get the Is element edges displayed
-
IsElementedges_BottomLabeling
(bool
) –Get the Is element edges bottom labeling
-
IsElementedges_MiddleLabeling
(bool
) –Get the Is element edges middle labeling
-
IsElementedges_TopLabeling
(bool
) –Get the Is element edges top labeling
-
IsHorizontalPositionPointDisplayed
(bool
) –Get the Is horizontal position point displayed
-
IsHorizontalPositionPoint_BottomLabeling
(bool
) –Get the Is horizontal position point bottom labeling
-
IsHorizontalPositionPoint_MiddleLabeling
(bool
) –Get the Is horizontalPositionPoint_Middle labeling
-
IsHorizontalPositionPoint_TopLabeling
(bool
) –Get the Is horizontal position point top labeling
-
IsStationPointDisplayed
(bool
) –Get the Is station point displayed
-
IsStationPoint_BottomLabeling
(bool
) –Get the Is station point bottom labeling
-
IsStationPoint_MiddleLabeling
(bool
) –Get the Is station point middle labeling
-
IsStationPoint_TopLabeling
(bool
) –Get the Is station point_Top labeling
-
IsZeroAxDisplayed
(bool
) –Get the Is zero axis displayed
-
IsZeroAx_BottomLabeling
(bool
) –Get the Is zero Axis bottom labeling
-
IsZeroAx_MiddleLabeling
(bool
) –Get the Is zero axis middle labeling
-
IsZeroAx_TopLabeling
(bool
) –Get the Is zero Axis top labeling
-
LabelingType
(int
) –Get the LabelingType
-
Offset
(float
) –Get the Offset
IsElementedgesDisplayed
property
writable
Get the Is element edges displayed
IsElementedges_BottomLabeling
property
writable
Get the Is element edges bottom labeling
IsElementedges_MiddleLabeling
property
writable
Get the Is element edges middle labeling
IsElementedges_TopLabeling
property
writable
Get the Is element edges top labeling
IsHorizontalPositionPointDisplayed
property
writable
Get the Is horizontal position point displayed
IsHorizontalPositionPoint_BottomLabeling
property
writable
Get the Is horizontal position point bottom labeling
IsHorizontalPositionPoint_MiddleLabeling
property
writable
Get the Is horizontalPositionPoint_Middle labeling
IsHorizontalPositionPoint_TopLabeling
property
writable
Get the Is horizontal position point top labeling
IsStationPointDisplayed
property
writable
Get the Is station point displayed
IsStationPoint_BottomLabeling
property
writable
Get the Is station point bottom labeling
IsStationPoint_MiddleLabeling
property
writable
Get the Is station point middle labeling
IsStationPoint_TopLabeling
property
writable
Get the Is station point_Top labeling
IsZeroAx_BottomLabeling
property
writable
Get the Is zero Axis bottom labeling
IsZeroAx_MiddleLabeling
property
writable
Get the Is zero axis middle labeling
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathSectionViewProperties)