Skip to content

SectionLayerProperties

Canonical path: NemAll_Python_BasisElements.SectionLayerProperties

Class containing settings regarding which layers are to be considered in a UVS

eVisibilityFilterMode

Canonical path: NemAll_Python_BasisElements.SectionLayerProperties.eVisibilityFilterMode

Bases: Enum

Visible filter mode

__getitem__

__getitem__(key: str | int | float) -> eVisibilityFilterMode

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

SetLayerProperties

SetLayerProperties(
    iVisibilityFilterMode: int,
    bAreInvisibleLyersStored: bool,
    layerIdVector: VecUShortList,
)

Set the layer properties

Parameters:

  • iVisibilityFilterMode (int) –

    Type of selected filter mode

  • bAreInvisibleLyersStored (bool) –

    When set to True, elements in excludedLayerList are filtered out. Otherwise elements in excludedLayerList are taken into consideration

  • layerIdVector (VecUShortList) –

    Elements belonging to these Layers should be filtered (excluded) from source up to flag bAreInvisibleLyersStored

__init__

__init__()

Initialize

Placeholder