Symbol3DElement
Canonical path: NemAll_Python_BasisElements.Symbol3DElement
Bases: BasisElement
, AllplanElement
Representation of the terrain point in Allplan
GetSymbol3DProperties
GetSymbol3DProperties() -> Symbol3DProperties
SetSymbol3DProperties
SetSymbol3DProperties(symbol3DProp: Symbol3DProperties)
__init__
overloaded
Initialize
__init__(
commonProp: CommonProperties,
Symbol3DProp: Symbol3DProperties,
geometryObject: object,
)
Constructor
Parameters:
-
commonProp
(CommonProperties
) –Common properties
-
symbol3DProp
–Symbol3D properties
-
geometryObject
(object
) –Geometry element
Placeholder