TextElementList
Canonical path: NemAll_Python_BasisElements.TextElementList
List for TextElement objects
__contains__
__contains__(value: TextElement) -> bool
Check for a value in the list
Parameters:
-
value
(TextElement
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: TextElement)
__eq__
__eq__(compare_list: TextElementList) -> bool
Compare two lists
Parameters:
-
compare_list
(TextElementList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
__getitem__(index: int) -> TextElement
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
TextElement
–Value for the index
__iadd__
__iadd__(eleList: list) -> TextElementList
Add a list
Parameters:
-
eleList
(list
) –TextElement list
Returns:
-
TextElementList
–Lists with the added elements
__init__
overloaded
Initialize
__init__(ele: TextElement)
Constructor with a list of TextElement
Parameters:
-
eleList
(list
) –TextElement list
__setitem__
__setitem__(index: int | slice, value: TextElement)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(TextElement
) –Value to item
append
append(value: TextElement)
extend
overloaded
extend(iterable: TextElementList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(TextElementList
) –Iterable to add
Extend the list
Parameters:
-
eleList
(list
) –TextElement list
Placeholder