TextLocation
Canonical path: NemAll_Python_BasisElements.TextLocation
Bases: Enum
Location of the dimension text relative to the dimension line
Attributes:
-
eBASIS_DIM_BOTTOM_CENTER
–Below the line, in the middle
-
eBASIS_DIM_BOTTOM_LEFT
–Below the line, at the start
-
eBASIS_DIM_BOTTOM_RIGHT
–Below the line, at the end
-
eBASIS_DIM_CENTER
–On the line, in the middle
-
eBASIS_DIM_CENTER_LEFT
–On the line, at the start
-
eBASIS_DIM_CENTER_RIGHT
–On the line, at the end
-
eBASIS_DIM_NONE
–Undefined
-
eBASIS_DIM_TOP_CENTER
–Above the line, in the middle
-
eBASIS_DIM_TOP_LEFT
–Above the line, at the start
-
eBASIS_DIM_TOP_RIGHT
–Above the line, at the end
eBASIS_DIM_BOTTOM_CENTER
class-attribute
instance-attribute
Below the line, in the middle
eBASIS_DIM_BOTTOM_LEFT
class-attribute
instance-attribute
Below the line, at the start
eBASIS_DIM_BOTTOM_RIGHT
class-attribute
instance-attribute
Below the line, at the end
eBASIS_DIM_CENTER
class-attribute
instance-attribute
On the line, in the middle
eBASIS_DIM_CENTER_LEFT
class-attribute
instance-attribute
On the line, at the start
eBASIS_DIM_CENTER_RIGHT
class-attribute
instance-attribute
On the line, at the end
eBASIS_DIM_TOP_CENTER
class-attribute
instance-attribute
Above the line, in the middle
eBASIS_DIM_TOP_LEFT
class-attribute
instance-attribute
Above the line, at the start
Placeholder