AxisPlacement3D
Canonical path: NemAll_Python_Geometry.AxisPlacement3D
Representation class for orthogonal axis placement in 3D space
Placement is given by Origin and 2 direction vectors - local x-axis and local z-axis. y-axis is computed on demand
Methods:
-
CalcGlobalPoint
–Calculate global point from local coordinate system of placement 3D
-
CalcLocalPoint
–Calculate local point in coordinate system of placement 3D
-
GetOrigin
–Get origin
-
GetRotationMatrix
–Get Rotation matrix given by placement 3D
-
GetTransformationMatrix
–Get Transformation matrix given by placement 3D
-
GetXDirection
–Get x-direction
-
GetYDirection
–Get direction of local y-axis
-
GetZDirection
–Get z-direction
-
IsValid
–Check if the placement is valid
-
RotateAroundLocalZAxis
–Rotate the placement around it's Z-axis
-
Set
–Set the placement
-
SetOrigin
–Set origin
-
SetXDirection
–Set x-direction
-
SetZDirection
–Set z-direction
-
__eq__
–Comparison of axis placements.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Origin
(Point3D
) –Get origin
-
XDirection
(Vector3D
) –Get x-direction
-
ZDirection
(Vector3D
) –Get z-direction
CalcGlobalPoint
CalcLocalPoint
GetRotationMatrix
GetRotationMatrix() -> Matrix3D
GetTransformationMatrix
GetTransformationMatrix() -> Matrix3D
GetXDirection
GetXDirection() -> Vector3D
GetYDirection
GetYDirection() -> Vector3D
GetZDirection
GetZDirection() -> Vector3D
IsValid
Check if the placement is valid
Returns:
-
bool
–True if it is a valid placement
RotateAroundLocalZAxis
RotateAroundLocalZAxis(angle: Angle)
Set
SetXDirection
SetXDirection(dir: Vector3D)
SetZDirection
SetZDirection(dir: Vector3D)
__eq__
__eq__(axis_placement: AxisPlacement3D) -> bool
Comparison of axis placements.
Be careful, this method work without tolerance!
Parameters:
-
axis_placement
(AxisPlacement3D
) –axis placement to be compared.
Returns:
-
bool
–True when axis placements are equal, otherwise false.
__init__
overloaded
Initialize
__init__(placement: AxisPlacement3D)
__init__(refPoint: Point3D)
__init__(matrix: Matrix3D)