BSpline2DList
Canonical path: NemAll_Python_Geometry.BSpline2DList
List for BSpline2D objects
__contains__
__contains__(value: BSpline2D) -> bool
Check for a value in the list
Parameters:
-
value
(BSpline2D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: BSpline2D)
__eq__
__eq__(compare_list: BSpline2DList) -> bool
Compare two lists
Parameters:
-
compare_list
(BSpline2DList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
__getitem__(index: int) -> BSpline2D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
BSpline2D
–Value for the index
__iadd__
__iadd__(eleList: list) -> BSpline2DList
Add a list
Parameters:
-
eleList
(list
) –BSpline2D list
Returns:
-
BSpline2DList
–Lists with the added elements
__init__
overloaded
Initialize
__init__(ele: BSpline2D)
Constructor with a list of BSpline2D
Parameters:
-
eleList
(list
) –BSpline2D list
__setitem__
__setitem__(index: int | slice, value: BSpline2D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(BSpline2D
) –Value to item
extend
overloaded
extend(iterable: BSpline2DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(BSpline2DList
) –Iterable to add
Extend the list
Parameters:
-
eleList
(list
) –BSpline2D list
Placeholder