ClosedArea3DList
Canonical path: NemAll_Python_Geometry.ClosedArea3DList
__contains__
__contains__(value: ClosedArea3D) -> bool
Check for a value in the list
Parameters:
-
value
(ClosedArea3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: ClosedArea3D)
__getitem__
__getitem__(index: int) -> ClosedArea3D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
ClosedArea3D
–Value for the index
__setitem__
__setitem__(index: int | slice, value: ClosedArea3D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(ClosedArea3D
) –Value to item
append
append(value: ClosedArea3D)
extend
extend(iterable: ClosedArea3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(ClosedArea3DList
) –Iterable to add
Placeholder