ClosedAreaComposite2D
Canonical path: NemAll_Python_Geometry.ClosedAreaComposite2D
2D closed area composite Representation class for 2D geometry closed (path bounded) area composite
Methods:
-
Add
–Add new area
-
Clear
–Clear contents of this composite
-
GetProfile
–Get profile from list of profiles
-
GetProfileCount
–Get count of profiles (areas)
-
GetProfileList
–Get const reference to vector of profiles
-
IsEmpty
–Check if this composite has any contents ( areas )
-
__eq__
–Comparison of closedAreaComposites without tolerance.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert the list to a string
Attributes:
-
ProfileList
(None
) –Get the profile list as property
Add
Add(area: ClosedArea2D) -> bool
Add new area
Parameters:
-
area
(ClosedArea2D
) –New area
Returns:
-
bool
–true if the operation was successful
GetProfile
GetProfile(index: int) -> ClosedArea2D
Get profile from list of profiles
Parameters:
-
index
(int
) –Index of profile in vector of profiles
Returns:
-
ClosedArea2D
–reference to profile
GetProfileCount
Get count of profiles (areas)
Returns:
-
int
–size_t - count of profiles (areas)
GetProfileList
GetProfileList() -> ClosedArea2DList
Get const reference to vector of profiles
Returns:
-
ClosedArea2DList
–const reference to vector of profiles
IsEmpty
Check if this composite has any contents ( areas )
Returns:
-
bool
–true if it is empty
__eq__
__eq__(closedAreaComposite: ClosedAreaComposite2D) -> object
Comparison of closedAreaComposites without tolerance.
Be careful, this method work without tolerance!
Parameters:
-
closedAreaComposite
(ClosedAreaComposite2D
) –Compared closedAreaComposite.
Returns:
-
object
–True when closedAreaComposites are equal, otherwise false.
__init__
overloaded
Initialize
__init__(composite: ClosedAreaComposite2D)
Copy constructor
Parameters:
-
composite
(ClosedAreaComposite2D
) –Area composite which will be copied.