ClosedAreaComposite2DList
Canonical path: NemAll_Python_Geometry.ClosedAreaComposite2DList
__contains__
__contains__(value: ClosedAreaComposite2D) -> bool
Check for a value in the list
Parameters:
-
value
(ClosedAreaComposite2D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: ClosedAreaComposite2D)
__getitem__
__getitem__(index: int) -> ClosedAreaComposite2D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
ClosedAreaComposite2D
–Value for the index
__setitem__
__setitem__(index: int | slice, value: ClosedAreaComposite2D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(ClosedAreaComposite2D
) –Value to item
append
append(value: ClosedAreaComposite2D)
extend
extend(iterable: ClosedAreaComposite2DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(ClosedAreaComposite2DList
) –Iterable to add
Placeholder