ClosedAreaComposite3DList
Canonical path: NemAll_Python_Geometry.ClosedAreaComposite3DList
__contains__
__contains__(value: ClosedAreaComposite3D) -> bool
Check for a value in the list
Parameters:
-
value
(ClosedAreaComposite3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: ClosedAreaComposite3D)
__getitem__
__getitem__(index: int) -> ClosedAreaComposite3D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
ClosedAreaComposite3D
–Value for the index
__setitem__
__setitem__(index: int | slice, value: ClosedAreaComposite3D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(ClosedAreaComposite3D
) –Value to item
append
append(value: ClosedAreaComposite3D)
extend
extend(iterable: ClosedAreaComposite3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(ClosedAreaComposite3DList
) –Iterable to add
Placeholder