ConicalSurface3DList
Canonical path: NemAll_Python_Geometry.ConicalSurface3DList
__contains__
__contains__(value: ConicalSurface3D) -> bool
Check for a value in the list
Parameters:
-
value
(ConicalSurface3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: ConicalSurface3D)
__getitem__
__getitem__(index: int) -> ConicalSurface3D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
ConicalSurface3D
–Value for the index
__setitem__
__setitem__(index: int | slice, value: ConicalSurface3D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(ConicalSurface3D
) –Value to item
append
append(value: ConicalSurface3D)
extend
extend(iterable: ConicalSurface3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(ConicalSurface3DList
) –Iterable to add
Placeholder