Cuboid3DList
Canonical path: NemAll_Python_Geometry.Cuboid3DList
__contains__
__contains__(value: Cuboid3D) -> bool
Check for a value in the list
Parameters:
-
value
(Cuboid3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: Cuboid3D)
__getitem__
__getitem__(index: int) -> Cuboid3D
__setitem__
__setitem__(index: int | slice, value: Cuboid3D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(Cuboid3D
) –Value to item
extend
extend(iterable: Cuboid3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(Cuboid3DList
) –Iterable to add
Placeholder