Skip to content

FaceOffset

Canonical path: NemAll_Python_Geometry.FaceOffset

Service for offset of faces of the element

eFaceOffsetDirection

Canonical path: NemAll_Python_Geometry.FaceOffset.eFaceOffsetDirection

Bases: Enum

Face offset direction

eNormalDirection : Direction of surface normal vector eOppositeDirection: Opposite direction to surface normal vector eBothSide : In both directions

__getitem__

__getitem__(key: str | int | float) -> eFaceOffsetDirection

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

IsResultBrep

IsResultBrep() -> bool

returns if selected object has brep geometry

Returns:

  • bool

    true if brep

Offset

Offset(
    offsetDistance: float,
    direction: eFaceOffsetDirection,
    useOffsetStepPierce: bool,
    useOrthoVXSplit: bool,
    punchDirection: Vector3D | None = None,
) -> tuple[eGeometryErrorCode, Any, Any]

Execute face offset

Parameters:

  • offsetDistance (float) –

    distance for offset

  • direction (eFaceOffsetDirection) –

    offset direction 0 - in face normal direction, 1 - in both directions, 2 - opposite to face normal

  • useOffsetStepPierce (bool) –

    if to use offset step pierce

  • useOrthoVXSplit (bool) –

    if to use OrthoVXSplit option

  • punchDirection (Vector3D | None, default: None ) –

    defined direction for offset (optional)

Returns:

  • tuple[eGeometryErrorCode, Any, Any]

    tuple(eOK if success, first resulting geometry, second resulting geometry, set only if offset in both direction is performed)

Shell

Shell(
    offsetDistance: float,
    direction: eFaceOffsetDirection,
    useOffsetStepPierce: bool,
    useOrthoVXSplit: bool,
    punchDirection: Vector3D | None = None,
) -> tuple[eGeometryErrorCode, Any]

Execute face shell

Parameters:

  • offsetDistance (float) –

    distance for offset

  • direction (eFaceOffsetDirection) –

    offset direction 0 - in face normal direction, 1 - in both directions, 2 - opposite to face normal

  • useOffsetStepPierce (bool) –

    if to use offset step pierce

  • useOrthoVXSplit (bool) –

    if to use OrthoVXSplit option

  • punchDirection (Vector3D | None, default: None ) –

    defined direction for shell (optional)

Returns:

__init__ overloaded

__init__(inputPolyhedron: Polyhedron3D)

Constructor with polyhedron input geometry

Parameters:

  • inputPolyhedron (Polyhedron3D) –

    polyhedron to execute face offset/shell on

__init__(inputPolyhedron: Polyhedron3D, faceIndices: VecSizeTList)

Constructor with polyhedron element

Parameters:

  • inputPolyhedron (Polyhedron3D) –

    polyhedron to execute face offset/shell on

  • faceIndices (VecSizeTList) –

    vector of indices of faces to offset/shell

__init__(inputBRep: BRep3D)

Constructor with brep element

Parameters:

  • inputBRep (BRep3D) –

    brep to execute face offset/shell on

__init__(inputBRep: BRep3D, faceIndices: VecSizeTList)

Constructor with brep element

Parameters:

  • inputBRep (BRep3D) –

    brep to execute face offset/shell on

  • faceIndices (VecSizeTList) –

    vector of indices of faces for offset/shell

__init__(element: FaceOffset)

Copy constructor

Parameters:

Placeholder