Point3DList
Canonical path: NemAll_Python_Geometry.Point3DList
List for Point3D objects
__contains__
__contains__(value: Point3D) -> bool
Check for a value in the list
Parameters:
-
value
(Point3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: Point3D)
__eq__
__eq__(compare_list: Point3DList) -> bool
Compare two lists
Parameters:
-
compare_list
(Point3DList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
__getitem__(index: int) -> Point3D
__iadd__
__iadd__(eleList: list) -> Point3DList
Add a list
Parameters:
-
eleList
(list
) –Point3D list
Returns:
-
Point3DList
–Lists with the added elements
__init__
overloaded
Initialize
__init__(ele: Point3D)
Constructor with a list of Point3D
Parameters:
-
eleList
(list
) –Point3D list
__setitem__
__setitem__(index: int | slice, value: Point3D)
extend
overloaded
extend(iterable: Point3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(Point3DList
) –Iterable to add
Extend the list
Parameters:
-
eleList
(list
) –Point3D list
Placeholder