PolyPoints2D
Canonical path: NemAll_Python_Geometry.PolyPoints2D
The PolyPoints class is the base template class for all objects which store geometry as a vector of points (or another objects), specially for polyline, polygon and spline.
Methods:
-
Clear
–Remove all points from vector.
-
Count
–Get count of points.
-
Empty
–Return true if no points, otherwise false.
-
EqualRef
–Test if reference points are equal.
-
GetEndPoint
–Get the end point in world coordinate system.
-
GetEndRelPoint
–Get the end point
-
GetLastPoint
–Get the last point in world coordinate system, data.
-
GetPoint
–Get point in world coordinate system, data.
-
GetPointIndex
–Get index of the given point
-
GetPointIndexes
–Get indexes of the given point, in case that several points in the spline
-
GetRefPoint
–Get reference point.
-
GetRelPoint
–Get point in Local coordinate system, no data.
-
GetStartPoint
–Get the start point in world coordinate system.
-
GetStartRelPoint
–Get the start point
-
Insert
–Overloaded function. See individual overloads.
-
InsertRel
–Insert relative point at specific position. Used local coordinates.
-
Remove
–Remove point from specific position.
-
RemoveLastPoint
–Remove the last point
-
Reserve
–Reserve container capacity
-
Resize
–Specifies a new size for the points vector.
-
Reverse
–Reverse the point order
-
SetEndPoint
–Set the end point in world coordinates
-
SetPoint
–Set point at given position in world coordinate system.
-
SetRefPoint
–Set reference point in world coordinate system.
-
SetRelPoint
–Set point at given position in relative coordinate system.
-
SetStartPoint
–Set the start point in world coordinates
-
ToLineChain
–Get polyline as a chain of lines composed from 2 points.
-
__getitem__
–Get point at position from index. Used world coordinates.
-
__iadd__
–Add point in world coordinates.
-
__mul__
–2D matrix transformation
-
__setitem__
–Set point at position from index. Used world coordinates.
Attributes:
-
EndPoint
(Point2D
) –Get the end point in world coordinate system.
-
EndRelPoint
(Point2D
) –Get the end point
-
Points
(list[Point2D]
) –Get the point list
-
RefPoint
(Point2D
) –Get reference point.
-
StartPoint
(Point2D
) –Get the start point in world coordinate system.
-
StartRelPoint
(Point2D
) –Get the start point
EqualRef
EqualRef(polyPoints: PolyPoints2D) -> bool
Test if reference points are equal.
Parameters:
-
polyPoints
(PolyPoints2D
) –constant the PolyPoints.
Returns:
-
bool
–Reference points are equal: true/false
GetEndPoint
GetEndPoint() -> Point2D
Get the end point in world coordinate system.
Returns:
-
Point2D
–end point in world coordinate system
GetLastPoint
GetLastPoint() -> Point2D
Get the last point in world coordinate system, data.
Returns:
-
Point2D
–last point in world coordinate system
GetPoint
GetPoint(index: int) -> Point2D
Get point in world coordinate system, data.
This method is checked and throwing Geometry::Exception when index is out of range.
Parameters:
-
index
(int
) –point index.
Returns:
-
Point2D
–point point in world coordinate system.
GetPointIndex
GetPointIndexes
GetRefPoint
GetRefPoint() -> Point2D
Get reference point.
Returns:
-
Point2D
–constant the reference point in the world coordinate system.
GetRelPoint
GetRelPoint(index: int) -> Point2D
Get point in Local coordinate system, no data.
This method is checked and throwing Geometry::Exception when index is out of range.
Parameters:
-
index
(int
) –point index.
Returns:
-
Point2D
–point constant the point at position index.
GetStartPoint
GetStartPoint() -> Point2D
Get the start point in world coordinate system.
Returns:
-
Point2D
–start point in world coordinate system
Insert
overloaded
Insert(polyPoints: PolyPoints2D, position: int = 18446744073709551615) -> bool
Insert vector of points at specific position.
If return false then points weren't inserted.
Parameters:
-
polyPoints
(PolyPoints2D
) –constant the PolyPoints.
-
position
(int
, default:18446744073709551615
) –position where points will be inserted.
Returns:
-
bool
–bool true if successful.
Insert(point: Point2D, position: int = 18446744073709551615) -> bool
Insert point at specific position. Used world coordinates.
If return false then points weren't Inserted.
Parameters:
-
point
(Point2D
) –constant the Point.
-
position
(int
, default:18446744073709551615
) –position where points will be inserted.
Returns:
-
bool
–bool true if successful.
InsertRel
InsertRel(point: Point2D, position: int = 18446744073709551615) -> bool
Insert relative point at specific position. Used local coordinates.
If return false then points weren't Inserted.
Parameters:
-
point
(Point2D
) –constant the Point.
-
position
(int
, default:18446744073709551615
) –position where points will be inserted.
Returns:
-
bool
–bool true if successful.
Remove
Remove point from specific position.
If return false then points weren't removed.
Parameters:
-
position
(int
) –position of point which will be removed.
Returns:
-
bool
–Point removed: true/false
RemoveLastPoint
Remove the last point
Returns:
-
bool
–Point removed: true/false
Reserve
Reserve container capacity
Parameters:
-
newCount
(int
) –Expected size of container [count of points]
Resize
Specifies a new size for the points vector.
Parameters:
-
newSize
(int
) –The new size of the points vector.
SetEndPoint
SetEndPoint(endpoint: Point2D)
SetPoint
SetPoint(point: Point2D, index: int)
Set point at given position in world coordinate system.
Parameters:
-
point
(Point2D
) –point in the world coordinate system.
-
index
(int
) –index of point which will be set
SetRefPoint
SetRefPoint(refPoint: Point2D)
Set reference point in world coordinate system.
Parameters:
-
refPoint
(Point2D
) –reference point in the world coordinate system.
SetRelPoint
SetRelPoint(point: Point2D, index: int)
Set point at given position in relative coordinate system.
Parameters:
-
point
(Point2D
) –point in the relative coordinate system.
-
index
(int
) –index of point which will be set
SetStartPoint
SetStartPoint(startpoint: Point2D)
ToLineChain
ToLineChain() -> Point2DList
Get polyline as a chain of lines composed from 2 points.
Returns:
-
Point2DList
–vector of lines composed from 2 points (start and end point of a line)
__getitem__
__getitem__(index: int) -> Point2D
Get point at position from index. Used world coordinates.
This method is checked and throwing Geometry::Exception when index is out of range.
Parameters:
-
index
(int
) –point index.
Returns:
-
Point2D
–point.
__iadd__
__iadd__(point: Point2D) -> PolyPoints2D
Add point in world coordinates.
Parameters:
-
point
(Point2D
) –adding point.
Returns:
-
PolyPoints2D
–New point
__mul__
__mul__(matrix: Matrix2D) -> PolyPoints2D
2D matrix transformation
Parameters:
-
matrix
(Matrix2D
) –2D transformation matrix
Returns:
-
PolyPoints2D
–Transformed polyline
__setitem__
__setitem__(arg2: int, value: Point2D)
Set point at position from index. Used world coordinates.
This method is checked and throwing Geometry::Exception when index is out of range. Args: index: Specified position pnt: Point