Polygon2DList
Canonical path: NemAll_Python_Geometry.Polygon2DList
List for Polygon2D objects
__contains__
__contains__(value: Polygon2D) -> bool
Check for a value in the list
Parameters:
-
value
(Polygon2D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: Polygon2D)
__getitem__
__getitem__(index: int) -> Polygon2D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
Polygon2D
–Value for the index
__setitem__
__setitem__(index: int | slice, value: Polygon2D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(Polygon2D
) –Value to item
extend
extend(iterable: Polygon2DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(Polygon2DList
) –Iterable to add
Placeholder