Polygon3DList
Canonical path: NemAll_Python_Geometry.Polygon3DList
List for Polygon3D objects
Methods:
-
__contains__
–Check for a value in the list
-
__delitem__
–Delete a list item
-
__eq__
–Compare two lists
-
__getitem__
–Get a list item
-
__iadd__
–Add a list
-
__init__
–Overloaded function. See individual overloads.
-
__iter__
–List iterator
-
__len__
–Get the list length
-
__repr__
–Create a string from the elements of the list
-
__setitem__
–Set a list item
-
append
–Append a list item
-
extend
–Overloaded function. See individual overloads.
__contains__
__contains__(value: Polygon3D) -> bool
Check for a value in the list
Parameters:
-
value
(Polygon3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: Polygon3D)
__eq__
__eq__(compare_list: Polygon3DList) -> bool
Compare two lists
Parameters:
-
compare_list
(Polygon3DList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
__getitem__(index: int) -> Polygon3D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
Polygon3D
–Value for the index
__iadd__
__iadd__(eleList: list) -> Polygon3DList
Add a list
Parameters:
-
eleList
(list
) –Polygon3D list
Returns:
-
Polygon3DList
–Lists with the added elements
__init__
overloaded
Initialize
__init__(ele: Polygon3D)
Constructor with a list of Polygon3D
Parameters:
-
eleList
(list
) –Polygon3D list
__setitem__
__setitem__(index: int | slice, value: Polygon3D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(Polygon3D
) –Value to item
extend
overloaded
extend(iterable: Polygon3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(Polygon3DList
) –Iterable to add
Extend the list
Parameters:
-
eleList
(list
) –Polygon3D list