Polyhedron3DList
Canonical path: NemAll_Python_Geometry.Polyhedron3DList
List for Polyhedron3D objects
Methods:
-
__contains__
–Check for a value in the list
-
__delitem__
–Delete a list item
-
__eq__
–Compare two lists
-
__getitem__
–Get a list item
-
__iadd__
–Add a list
-
__init__
–Overloaded function. See individual overloads.
-
__iter__
–List iterator
-
__len__
–Get the list length
-
__repr__
–Create a string from the elements of the list
-
__setitem__
–Set a list item
-
append
–Append a list item
-
extend
–Overloaded function. See individual overloads.
__contains__
__contains__(value: Polyhedron3D) -> bool
Check for a value in the list
Parameters:
-
value
(Polyhedron3D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: Polyhedron3D)
__eq__
__eq__(compare_list: Polyhedron3DList) -> bool
Compare two lists
Parameters:
-
compare_list
(Polyhedron3DList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
__getitem__(index: int) -> Polyhedron3D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
Polyhedron3D
–Value for the index
__iadd__
__iadd__(eleList: list) -> Polyhedron3DList
Add a list
Parameters:
-
eleList
(list
) –Polyhedron3D list
Returns:
-
Polyhedron3DList
–Lists with the added elements
__init__
overloaded
Initialize
__init__(ele: Polyhedron3D)
Constructor with a list of Polyhedron3D
Parameters:
-
eleList
(list
) –Polyhedron3D list
__setitem__
__setitem__(index: int | slice, value: Polyhedron3D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(Polyhedron3D
) –Value to item
append
append(value: Polyhedron3D)
extend
overloaded
extend(iterable: Polyhedron3DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(Polyhedron3DList
) –Iterable to add
Extend the list
Parameters:
-
eleList
(list
) –Polyhedron3D list