Polyline2DList
Canonical path: NemAll_Python_Geometry.Polyline2DList
List for Polyline2D objects
__contains__
__contains__(value: Polyline2D) -> bool
Check for a value in the list
Parameters:
-
value
(Polyline2D
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: Polyline2D)
__getitem__
__getitem__(index: int) -> Polyline2D
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
Polyline2D
–Value for the index
__setitem__
__setitem__(index: int | slice, value: Polyline2D)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(Polyline2D
) –Value to item
append
append(value: Polyline2D)
extend
extend(iterable: Polyline2DList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(Polyline2DList
) –Iterable to add
Placeholder