Skip to content

eFilletType

Canonical path: NemAll_Python_Geometry.eFilletType

Bases: Enum

Enumeration for the type of Fillet

FT_UNKNOWN : Unknown fillet type FT_LL_INTERSECTION_ON_LINE : Intersection of two lines is on line FT_LL_INTERSECTION_AT_THE_END : Intersection of two lines is at the end of lines FT_LL_INTERSECTION_OUT_OF_LINES: Intersection of two lines is out of lines FT_LL_PARALLEL_LINES : Intersection of two Lines are parallel FT_LC_TWO_INTERSECTION : Intersection of line and circle - two intersections FT_LC_ONE_INTERSECTION : Intersection of line and circle - one intersections FT_LC_NO_INTERSECTION : Intersection of line and circle - no intersections FT_CC_TWO_INTERSECTION : Intersection of two circles - two intersections FT_CC_ONE_INTERSECTION : Intersection of two circles - one intersections FT_CC_NO_INTERSECTION : Intersection of two circles - no intersections FT_CC_CONCETRIC : Concentric lines - no intersections FT_KK_KURVE_ELEMENTS : Intersection of two curve elements FT_KK_PARALLEL_KURVE_ELEMENTS : Intersection of two parallel curve elements

FT_CC_CONCETRIC class-attribute instance-attribute

FT_CC_CONCETRIC = 33

FT_CC_NO_INTERSECTION class-attribute instance-attribute

FT_CC_NO_INTERSECTION = 32

FT_CC_ONE_INTERSECTION class-attribute instance-attribute

FT_CC_ONE_INTERSECTION = 31

FT_CC_TWO_INTERSECTION class-attribute instance-attribute

FT_CC_TWO_INTERSECTION = 30

FT_KK_KURVE_ELEMENTS class-attribute instance-attribute

FT_KK_KURVE_ELEMENTS = 40

FT_KK_PARALLEL_KURVE_ELEMENTS class-attribute instance-attribute

FT_KK_PARALLEL_KURVE_ELEMENTS = 41

FT_LC_NO_INTERSECTION class-attribute instance-attribute

FT_LC_NO_INTERSECTION = 22

FT_LC_ONE_INTERSECTION class-attribute instance-attribute

FT_LC_ONE_INTERSECTION = 21

FT_LC_TWO_INTERSECTION class-attribute instance-attribute

FT_LC_TWO_INTERSECTION = 20

FT_LL_INTERSECTION_AT_THE_END class-attribute instance-attribute

FT_LL_INTERSECTION_AT_THE_END = 11

FT_LL_INTERSECTION_ON_LINE class-attribute instance-attribute

FT_LL_INTERSECTION_ON_LINE = 10

FT_LL_INTERSECTION_OUT_OF_LINES class-attribute instance-attribute

FT_LL_INTERSECTION_OUT_OF_LINES = 12

FT_LL_PARALLEL_LINES class-attribute instance-attribute

FT_LL_PARALLEL_LINES = 13

FT_UNKNOWN class-attribute instance-attribute

FT_UNKNOWN = 0
Placeholder