Skip to content

eProjectionMatrixType

Canonical path: NemAll_Python_Geometry.eProjectionMatrixType

Bases: Enum

Type of projection in Matrix3D

Used for an identification of what kind of projection is in Matrix3D.

LEFT_2D : -3 -> X RIGHT_2D : 3 -> -X FRONT_2D : -2 -> Y REAR_2D : 2 -> -Y TOP_2D : 1 -> -Z BOTTOM_2D: -1 -> Z FREE_3D : Free projection

BOTTOM_2D class-attribute instance-attribute

BOTTOM_2D = 5

FREE_3D class-attribute instance-attribute

FREE_3D = 6

FRONT_2D class-attribute instance-attribute

FRONT_2D = 2

LEFT_2D class-attribute instance-attribute

LEFT_2D = 0

REAR_2D class-attribute instance-attribute

REAR_2D = 3

RIGHT_2D class-attribute instance-attribute

RIGHT_2D = 1

TOP_2D class-attribute instance-attribute

TOP_2D = 4
Placeholder