eServiceResult
Canonical path: NemAll_Python_Geometry.eServiceResult
Bases: Enum
service result
Used for an identification of service functionality result
POSITIVE_ORIENTATION : Orientation Counter-Clockwise NEGATIVE_ORIENTATION : Orientation Clockwise NO_ERR : Error No error INVALID_LINE : Error Invalid Line INVALID_POLYLINE : Error Invalid Polyline INVALID_POLYGON : Error Invalid Polygon INVALID_POLYHEDRON : Error Invalid Polyhedron ZERO_ANGLE : Error Zero Angle PARALLEL_LINES : Lines are parallel INVALID_GEOOBJECT : Error Invalid Geo Object INVALID_POINT : Error Invalid Point INVALID_CUBOID : Error Invalid Cuboid INVALID_CYLINDER : Error Invalid Cylinder INVALID_CONE : Error Invalid Cone INVALID_ELLIPSOID : Error Invalid Ellipsoid INVALID_SURFACE : Error Invalid Surface FAILED_TO_INVERT_MATRIX: Error Matix inversion failed FAILED_TO_CONVERGE : Error method failed to converge INVALID_POINTCLOUD : Error Invalid point cloud IS_ABOVE : Geometry is ABOVE the element IS_BELOW : Geometry is BELOW the element IS_IN : Geometry is in, not above, not below IS_UNKNOWN : Geometry has not recognized position