AllplanElement
Canonical path: NemAll_Python_IFW_ElementAdapter.AllplanElement
Implementation of the Allplan element
Methods:
-
GetAttributes
–Get the attributes object
-
GetBaseElementAdapter
–Get the model element
-
GetCommonProperties
–Get the common properties
-
GetGeometryObject
–Get the geometry object
-
GetLabelElements
–Get the label elements
-
GetSubElementID
–Get the SubElementID
-
SetAttributes
–Set the attributes object
-
SetCommonProperties
–Set the common properties
-
SetDockingPointsKey
–Set the docking points key
-
SetGeometryObject
–Set the geometry object
-
SetLabelElements
–Set the label elements
Attributes:
-
Attributes
(object
) –Get the attributes object
-
CommonProperties
(CommonProperties
) –Get the common properties
-
GeometryObject
(object
) –Get the geometry object
-
LabelElements
(list
) –Get the label elements
GetAttributes
Get the attributes object
Returns:
-
object
–Attributes object
GetBaseElementAdapter
GetBaseElementAdapter() -> BaseElementAdapter
GetCommonProperties
GetCommonProperties() -> CommonProperties
GetGeometryObject
Get the geometry object
Returns:
-
object
–Geometry object
SetAttributes
Set the attributes object
Parameters:
-
attributeContainer
(object
) –Attributes object
SetCommonProperties
SetCommonProperties(commonProp: CommonProperties)
SetDockingPointsKey
Set the docking points key
Parameters:
-
dockingPointsKey
(str
) –Docking points key
SetGeometryObject
Set the geometry object
Parameters:
-
geoObject
(object
) –Geometry object
Placeholder