BaseElementAdapterChildElementsService
Canonical path: NemAll_Python_IFW_ElementAdapter.BaseElementAdapterChildElementsService
Implementation of the service functions for the child elements determination of a base element adapter
GetChildElements
staticmethod
GetChildElements(
ele: BaseElementAdapter, hiddenElements: bool
) -> BaseElementAdapterVector
Get the child elements of the element (includes the childs which have the same model element)
Parameters:
-
ele
(BaseElementAdapter
) –Element
-
hiddenElements
(bool
) –Include hidden elements: true/false
Returns:
-
BaseElementAdapterVector
–Child elements
GetChildModelElements
overloaded
GetChildModelElements(ele: BaseElementAdapter) -> BaseElementAdapterList
Get the child model elements of the element
Parameters:
-
ele
(BaseElementAdapter
) –BaseElementAdapter Element
Returns:
-
BaseElementAdapterList
–True, if element pass and can be selected
-
BaseElementAdapterList
–Child elements of the element
GetChildModelElements(
ele: BaseElementAdapter, hiddenElements: bool
) -> BaseElementAdapterList
Get the child model elements of the element
Parameters:
-
ele
(BaseElementAdapter
) –Element
-
hiddenElements
(bool
) –Include hidden elements: true/false
Returns:
-
BaseElementAdapterList
–Child elements including hidden elements of the element
GetChildModelElementsFromTree
staticmethod
GetChildModelElementsFromTree(
ele: BaseElementAdapter,
) -> BaseElementAdapterList
Get the child model elements from the complete child tree of the element
Parameters:
-
ele
(BaseElementAdapter
) –Element
Returns:
-
BaseElementAdapterList
–Child model elements from the complete child tree of the element
GetChildPropertyElements
staticmethod
GetChildPropertyElements(
ele: BaseElementAdapter, modifyState: object, propGroup: object
) -> BaseElementAdapterVector
Get the child property elements
Parameters:
-
ele
(BaseElementAdapter
) –Element
-
modifyState
(object
) –Modify state
-
propGroup
(object
) –Property group
Returns:
-
BaseElementAdapterVector
–Child property elements
GetTierElements
staticmethod
GetTierElements(ele: BaseElementAdapter) -> BaseElementAdapterVector
Get the tier elements from an element
Parameters:
-
ele
(BaseElementAdapter
) –Element
Returns:
-
BaseElementAdapterVector
–Tier elements
GetTierNumber
staticmethod
GetTierNumber(ele: BaseElementAdapter) -> int
Get the tier number from an element
Parameters:
-
ele
(BaseElementAdapter
) –Element
Returns:
-
int
–Tier number