Skip to content

BaseElementAdapterService

Canonical path: NemAll_Python_IFW_ElementAdapter.BaseElementAdapterService

Implementation of the base element adapter service

Methods:

AdaptElementsAfterTransaction staticmethod

AdaptElementsAfterTransaction(
    elements: BaseElementAdapterList,
) -> BaseElementAdapterList

Adapt the elements after a transaction (set new address, ...)

Parameters:

Returns:

GetConnectedElements staticmethod

GetConnectedElements(ele: BaseElementAdapter) -> BaseElementAdapterList

Get the connected elements (ivk2)

Parameters:

Returns:

GetDocumentIndex staticmethod

GetDocumentIndex(ele: BaseElementAdapter) -> int

Get the internal index of the element-document

Parameters:

Returns:

  • int

    Internal index of the element-document

GetLinkedElements staticmethod

GetLinkedElements(ele: BaseElementAdapter) -> BaseElementAdapterVector

Get the linked elements

Parameters:

Returns:

GetMacroElementAddress staticmethod

GetMacroElementAddress(ele: BaseElementAdapter) -> int

Get the array address of macro element, if exist

Parameters:

Returns:

  • int

    Address of macro if exist, otherwise 0

IsConnectedElement staticmethod

IsConnectedElement(ele1: BaseElementAdapter, ele2: BaseElementAdapter) -> bool

Check, whether the two elements are connected

Parameters:

Returns:

  • bool

    Elements are connected: true/false

IsElementFromElementGroup staticmethod

IsElementFromElementGroup(ele: BaseElementAdapter) -> bool

Check, whether the element is inside an element group

Parameters:

Returns:

  • bool

    Element is inside an element group

IsElementOrChildDeleted staticmethod

IsElementOrChildDeleted(ele: BaseElementAdapter) -> bool

Check, whether the element or a child element is deleted

Parameters:

Returns:

  • bool

    Element or child element is deleted

IsElementVisible staticmethod

IsElementVisible(ele: BaseElementAdapter) -> bool

Check, whether the element is visible

Parameters:

Returns:

  • bool

    Element is visible: true/false

IsPostActivation staticmethod

IsPostActivation(ele: BaseElementAdapter) -> bool

Get the post activation state from the element

Parameters:

Returns:

  • bool

    Element with post activation: true/false

IsTypeConnectedElement staticmethod

IsTypeConnectedElement(ele: BaseElementAdapter, eleTypes: object) -> bool

Check, whether the element is a type connected element

Parameters:

  • ele (BaseElementAdapter) –

    Element

  • eleTypes (object) –

    Type(s) of the connection element

Returns:

  • bool

    Text connected element: true/false