DocumentNameService
Canonical path: NemAll_Python_IFW_ElementAdapter.DocumentNameService
GetActiveDocumentName
staticmethod
Get the name of the active document
Returns:
-
str
–Name of the active document
GetDocumentName
staticmethod
GetDocumentName(
ele: BaseElementAdapter, withNumber: bool, withLabel: bool, delimiter: str
) -> str
Get the name of the element
Parameters:
-
ele
(BaseElementAdapter
) –Element
-
withNumber
(bool
) –Add the document number: true/false
-
withLabel
(bool
) –Add the label: true/false
-
delimiter
(str
) –Delimiter between number and name
Returns:
-
str
–Name of the document
GetDocumentNameByFileIndex
staticmethod
GetDocumentNameByFileIndex(
fileIndex: int, withNumber: bool, withLabel: bool, delimiter: str
) -> str
Get the document name by the document index (load index)
Parameters:
-
fileIndex
(int
) –Document file index
-
withNumber
(bool
) –Add the document number: true/false
-
withLabel
(bool
) –Add the label: true/false
-
delimiter
(str
) –Delimiter between number and name
Returns:
-
str
–Document name
GetDocumentNameByFileNumber
staticmethod
GetDocumentNameByFileNumber(
fileNumber: int, withNumber: bool, withLabel: bool, delimiter: str
) -> str
Get the document name by the file number
Parameters:
-
fileNumber
(int
) –Document file number
-
withNumber
(bool
) –Add the document number: true/false
-
withLabel
(bool
) –Add the label: true/false
-
delimiter
(str
) –Delimiter between number and name
Returns:
-
str
–Document name
Placeholder