ElementAdapterTypeGroup
Canonical path: NemAll_Python_IFW_ElementAdapter.ElementAdapterTypeGroup
Bases: Enum
Implementation of the element adapter type groups
eNO_GROUP : No type group eBREPS3D_GROUP : Group with the BReps elements eBREPS3D_SURFACE_GROUP : Group with the BReps surface elements eLINES3D_GROUP : Group with the 3D lines eCURVES3D_GROUP : Group with the 3D Curves eAREAS3D_GROUP : Group with the 3D Areas eVOLUMES3D_GROUP : Group with the 3D volumes eTEXT_GROUP : Group with the text elements eDIMENSION_GROUP : Group with the dimension elements eSMART_SYMBOL_GROUP : Group with the smart symbol elements eSMART_PART_GROUP : Group with the smart part elements eFIXTURE_GROUP : Group with the fixture elements eREVEAL_GROUP : Group with the reveal elements eXREF_GROUP : Group with the XRef elements ePYTHON_PART_GROUP : Group with the python part elements ePIPEWORK_GROUP : Group with the pipework elements ePIPEBUNDLE_GROUP : Group with the pipebundle elements eAXIS_ELEMENT_GROUP : Group with the axis elements eBARS_PLACEMENT_GROUP : Group with the bar placement elements eDEFECT_ELEMENT_GROUP : Group with the defect elements eWALL_OPENING_GROUP : Group with the wall openings eWALL_OPENING_SUB_ELEMENTS_GROUP: Group with the sub elements of the wall opening (tiers, lintel, ...) ePRECAST_GROUP : Precast elements eHYPERELEMENT_GROUP : Group with composite elements eOPENINGPART_GROUP : Group with openingpart elements eHYPERELEMENT_TIER_GROUP : Group with tier elements of hyper elements eLAST_GROUP : Index of the last group