CoordinateInputMode
Canonical path: NemAll_Python_IFW_Input.CoordinateInputMode
Settings regarding mode, in which elements and/or points should be identified during point input
GetIdentMode
GetIdentMode() -> eIdentificationMode
IsLocalCoordInput
Get the local coordinate input state
Returns:
-
bool
–Local coordinate input state
SetLocalCoordInput
Set the local coordinate input state
Parameters:
-
bLocalCoordInput
(bool
) –Only local coordinate input: true/false
__init__
overloaded
Initialize
__init__(
identMode: eIdentificationMode,
drawPointSymbol: eDrawElementIdentPointSymbols = eDrawElementIdentPointSymbols.eDRAW_IDENT_ELEMENT_POINT_SYMBOL_YES,
)
Constructor, sets the local coordinate input to false
Parameters:
-
identMode
(eIdentificationMode
) –Identification mode
-
drawPointSymbol
(eDrawElementIdentPointSymbols
, default:eDRAW_IDENT_ELEMENT_POINT_SYMBOL_YES
) –Draw the identification point symbol at the element (if an element is selected): true/false
__init__(identMode: eIdentificationMode, bLocalCoordInput: bool)
Constructor, sets the local coordinate input
Parameters:
-
identMode
(eIdentificationMode
) –Identification mode
-
bLocalCoordInput
(bool
) –Only local coordinate input: true/false
__init__(element: CoordinateInputMode)
Placeholder