PythonWpfPaletteBuilder
Canonical path: NemAll_Python_Palette.PythonWpfPaletteBuilder
Implementation of the Python WPF palette builder
AddAngleValue
AddAngleValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a angle value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
AddAreaFixtureCatalogRef
AddAreaFixtureCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add an area fixture precastcatalog reference - all, only point, line or area
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddAreaValue
AddAreaValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a area value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
AddBarDiameter
AddBarDiameter(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add an bar diameter value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddBendingRollerValue
AddBendingRollerValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a bending roller value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddBrickTileCatalogRef
AddBrickTileCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a brick/tile reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddButton
AddButton(
description: str,
name: str,
eventId: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontStyle: int,
fontFaceCode: int,
)
Add a button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
eventId
(int
) –Value holds the event ID pressing the button
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontStyle
(int
) –Font size: 0=small, 1=extra small, 2=large
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddCheckboxValue
AddCheckboxValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a checkbox value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddColorValue
AddColorValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a color value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddComboBoxValue
AddComboBoxValue(
description: str,
name: str,
value: str,
listValues: str,
ctrlType: PaletteCtrlType,
valueType: PaletteValueType,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
isEditable: bool,
)
Add a combo box value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value
-
listValues
(str
) –List values
-
ctrlType
(PaletteCtrlType
) –Control type
-
valueType
(PaletteValueType
) –Value type
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color
-
isEditable
(bool
) –Is editable state
AddConcreteCoverValue
AddConcreteCoverValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a concrete cover value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddConcreteGrade
AddConcreteGrade(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a concrete grade value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddConcreteGradeCatalogRef
AddConcreteGradeCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a concreteGrade reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddDoubleValue
AddDoubleValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a double value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
AddFaceStyleValue
AddFaceStyleValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a face style combobox to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –ID name
-
value
(int
) –Selected value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddFactoryCatalogRef
AddFactoryCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a factory precastcatalog reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddFixtureCatalogRef
AddFixtureCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a fixture precastcatalog reference - all, only point, line or area
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddFixtureValues
AddFixtureValues(
descriptionPath: str,
descriptionGroup: str,
descriptionElement: str,
name: str,
fixture: FixtureProperties,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add the fixture values
Parameters:
-
descriptionPath
(str
) –Description of the path value
-
descriptionGroup
(str
) –Description of the group value
-
descriptionElement
(str
) –Description of the element value
-
name
(str
) –Value name
-
fixture
(FixtureProperties
) –Properties of the fixture
-
page
(int
) –Pate
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddHatchValue
AddHatchValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a hatch combobox to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –ID name
-
value
(int
) –Selected value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddInsulationCatalogRef
AddInsulationCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a insulation reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddIntValue
AddIntValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add an integer value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
AddLayer
AddLayer(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a layer value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddLengthValue
AddLengthValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a length value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
AddLineFixtureCatalogRef
AddLineFixtureCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a line fixture precastcatalog reference - all, only point, line or area
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddMaterialButton
AddMaterialButton(
description: str,
name: str,
value: str,
buttonType: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a material button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –String of material
-
buttonType
(int
) –Button type (0: simple material button, 1: mat button + switch off button)
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddMeshGroup
AddMeshGroup(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a mesh group value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddMeshType
AddMeshType(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
meshGroup: int,
height: int,
width: int,
fontFaceCode: int,
)
Add a mesh type value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
meshGroup
(int
) –Mesh group
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddMultiMaterialLayoutCatalogRef
AddMultiMaterialLayoutCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
) -> int
Add a multimaterial layout catalog reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
ex
–of layout
AddNormCatalogRef
AddNormCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a norm catalog reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPage
Add a page to the palette
Parameters:
-
name
(str
) –ID name
-
description
(str
) –Description text (localized)
AddPatternValue
AddPatternValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a pattern combobox to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –ID name
-
value
(int
) –Selected value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPenValue
AddPenValue(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a pen value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPicture
AddPicture(
description: str,
name: str,
pictureName: str,
libPath: str,
orientation: Orientation,
page: int,
expanderName: str,
rowName: str,
)
Add a picture to the palette
Parameters:
-
description
(str
) –Description used for the tooltip
-
name
(str
) –ID name
-
pictureName
(str
) –Name of the picture
-
libPath
(str
) –Library path
-
orientation
(Orientation
) –Orientation (0:LEFT, 1:MIDDLE, 2:RIGHT)
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
AddPictureButton
AddPictureButton(
description: str,
name: str,
value: str,
eventId: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value
-
eventId
(int
) –Value holds the event ID pressing the button
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPictureButtonList
AddPictureButtonList(
description: str,
name: str,
value: int,
picturePath: str,
pictureList: str,
valueList: str,
textList: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture button list to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value holds the selected picture button in buttons
-
picturePath
(str
) –Path of pictures
-
pictureList
(str
) –Picture list holds the images for the buttons - example: a.png|b.png|c.png
-
valueList
(str
) –Value list of possible values - example: 0|1|2
-
textList
(str
) –Text list for the tooltips
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPictureComboBox
AddPictureComboBox(
description: str,
name: str,
value: int,
picturePath: str,
pictureList: str,
valueList: str,
textList: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture combobox to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value holds the selected picture button in buttons
-
picturePath
(str
) –Path of pictures
-
pictureList
(str
) –Picture list holds the images for the buttons - example: a.png|b.png|c.png
-
valueList
(str
) –Value list of possible values - example: 0|1|2
-
textList
(str
) –Text list for the tooltips
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPictureResourceButton
AddPictureResourceButton(
description: str,
name: str,
value: int,
eventId: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value holds the resource ID
-
eventId
(int
) –Value holds the event ID pressing the button
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPictureResourceButtonList
AddPictureResourceButtonList(
description: str,
name: str,
value: int,
pictureList: str,
valueList: str,
textList: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture resource button list to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value holds the selected picture button in buttons
-
pictureList
(str
) –Picture list holds the images for the buttons - example: 16433|16441|16449
-
valueList
(str
) –Value list of possible values - example: 0|1|2
-
textList
(str
) –Text list for the tooltips
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPictureResourceComboBox
AddPictureResourceComboBox(
description: str,
name: str,
value: int,
pictureList: str,
valueList: str,
textList: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture resource combobox to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value holds the selected picture button in buttons
-
pictureList
(str
) –Picture list holds the images for the buttons - example: 16433|16441|16449
-
valueList
(str
) –Value list of possible values - example: 0|1|2
-
textList
(str
) –Text list for the tooltips
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPictureResourceToggleButton
AddPictureResourceToggleButton(
description: str,
name: str,
value: int,
pictureList: str,
valueList: str,
textList: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a picture toggle button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value holds the selected picture button in buttons
-
pictureList
(str
) –Picture list holds the images for the buttons - example: a.png|b.png|c.png
-
valueList
(str
) –Value list of possible values - example: 0|1|2
-
textList
(str
) –Text list for the tooltips
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPlaneReferencesButton
AddPlaneReferencesButton(
description: str,
name: str,
planeRefs: BasePlaneReferences,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a plane references button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
planeRefs
(BasePlaneReferences
) –Plane references
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPointFixtureCatalogRef
AddPointFixtureCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a point fixture precastcatalog reference - all, only point, line or area
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddPrecastElementTypeCatalogRef
AddPrecastElementTypeCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
) -> str
Add a precastElementType catalog reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddRadioButton
AddRadioButton(
radioButtonGroupDescription: str,
radioButtonGroupName: str,
radioButtonDescription: str,
value: object,
selectedValueInGroup: object,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a radio button to the palette
Parameters:
-
radioButtonGroupDescription
(str
) –Radio button group description
-
radioButtonGroupName
(str
) –Radio button group ID name
-
radioButtonDescription
(str
) –Radio button description
-
value
(object
) –Double value of this radio button
-
selectedValueInGroup
(object
) –Selected value of radio button group
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddRefPointButton
AddRefPointButton(
description: str,
name: str,
refPointPosition: RefPointPosition,
refPointType: RefPointButtonType,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a reference point button to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
refPointPosition
(RefPointPosition
) –Reference point ID (1,...,9)
-
refPointType
(RefPointButtonType
) –Reference point type
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddResourcePicture
AddResourcePicture(
description: str,
name: str,
pictureResourceID: int,
page: int,
expanderName: str,
rowName: str,
height: int,
width: int,
)
Add a picture from a resource to the palette
Parameters:
-
description
(str
) –Description used for the tooltip
-
name
(str
) –ID name
-
pictureResourceID
(int
) –Resource id of the picture
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
AddSeparator
Add a separator to the palette
Parameters:
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
AddSteelGrade
AddSteelGrade(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a steel grade value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddStringValue
AddStringValue(
description: str,
name: str,
str: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a string value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
str
(str
) –String
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddStroke
AddStroke(
description: str,
name: str,
value: int,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a stroke value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(int
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddSurfaceCatalogRef
AddSurfaceCatalogRef(
description: str,
name: str,
value: str,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontFaceCode: int,
)
Add a Surface catalog reference
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(str
) –Value string
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddText
AddText(
description: str,
value: str,
orientation: Orientation,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
height: int,
width: int,
fontStyle: int,
fontFaceCode: int,
)
Add a text
Parameters:
-
description
(str
) –Description
-
value
(str
) –Value
-
orientation
(Orientation
) –Page index
-
page
(int
) –Expander section name
-
expanderName
(str
) –Name of the row
-
rowName
(str
) –Control is enabled: true/false
-
bEnabled
(bool
) –Control height, only used for a row
-
height
(int
) –Control width, only used for a row
-
width
(int
) –Font size: 0=small, 1=extra small, 2=large
-
fontStyle
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
AddVolumeValue
AddVolumeValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a volume value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
AddWeightValue
AddWeightValue(
description: str,
name: str,
value: float,
page: int,
expanderName: str,
rowName: str,
bEnabled: bool,
minValue: float,
maxValue: float,
intervalValue: float,
asSlider: bool,
height: int,
width: int,
fontFaceCode: int,
backgroundColor: list[int] | VecIntList,
)
Add a weight value to the palette
Parameters:
-
description
(str
) –Description
-
name
(str
) –Value name
-
value
(float
) –Value
-
page
(int
) –Page index
-
expanderName
(str
) –Expander section name
-
rowName
(str
) –Name of the row
-
bEnabled
(bool
) –Control is enabled: true/false
-
minValue
(float
) –Minimal value
-
maxValue
(float
) –Maximal value
-
intervalValue
(float
) –Interval value for the slider
-
asSlider
(bool
) –Show as slider: true/false
-
height
(int
) –Control height, only used for a row
-
width
(int
) –Control width, only used for a row
-
fontFaceCode
(int
) –Face code: 0=normal, 1=bold, 2=italic, 4=underline
-
backgroundColor
(list[int] | VecIntList
) –Background color of the control as red, green, blue
IsConcreteCoverPaletteUpdate
Check for a palette update due to a new concrete cover
Parameters:
-
cover
(float
) –Concrete cover
Returns:
-
bool
–Palette update: true/false
__init__
__init__(element: PythonWpfPaletteBuilder)