NemAll_Python_Reinforcement
Exposed classes and functions from NemAll_Python_Reinforcement
CreateReinforcementLabeling
overloaded
CreateReinforcementLabeling(
doc: DocumentAdapter,
insertionMat: Matrix3D,
labelList: list,
viewProj: ViewWorldProjection,
undoRedoService: object | None = None,
)
Create the reinforcement labels
Parameters:
-
doc
(DocumentAdapter
) –Document
-
insertionMat
(Matrix3D
) –Insertion matrix
-
modelEleList
–List with the model elements
-
viewProj
(ViewWorldProjection
) –View projection
-
undoRedoService
(object | None
, default:None
) –Undo redo service
CreateReinforcementLabeling(
doc: DocumentAdapter,
insertionMat: Matrix3D,
labelList: ReinforcementLabelList,
viewProj: ViewWorldProjection,
)
Create the reinforcement labels
Parameters:
-
doc
(DocumentAdapter
) –Document
-
insertionMat
(Matrix3D
) –Insertion matrix
-
labelList
(ReinforcementLabelList
) –List with the labels
-
viewProj
(ViewWorldProjection
) –View projection
Placeholder