BarAreaPlacementService
Canonical path: NemAll_Python_Reinforcement.BarAreaPlacementService
AddOpeningPolygon
AddOpeningPolygon(arg2: Polygon3D, openingPol: float)
Add an opening polygon
Parameters:
-
openingPol
(float
) –Opening polygon
Calculate
Calculate(
doc: DocumentAdapter,
barPlacementProp: BarAreaPlacementProperties,
placementMatrix: Matrix3D,
concreteCoverZDir: float,
) -> list
Calculate the meshes
Parameters:
-
doc
(DocumentAdapter
) –Document
-
barPlacementProp
(BarAreaPlacementProperties
) –Placement properties
-
placementMatrix
(Matrix3D
) –Placement matrix
-
concreteCoverZDir
(float
) –Concrete cover in the local z direction
SetOuterPolygon
SetOuterPolygon(arg2: Polygon3D, placementPol: float)
Constructor
Parameters:
-
placementPol
(float
) –Placement polygon
Placeholder