BarPlacement
Canonical path: NemAll_Python_Reinforcement.BarPlacement
Bases: ReinfElement
, AllplanElement
Implementation of the bar placement element
Methods:
-
GetBarCount
–Get the bar count
-
GetBendingShape
–Get the shape polyline
-
GetBendingShapeMatrix
–Get the bending shape matrix
-
GetCommonProperties
–Get the common properties
-
GetDistanceVector
–Get the distance vector
-
GetEndBendingShape
–Get the shape polyline at the end of a polygonal placement
-
GetEndPoint
–Get the end point of the placement at the placement line
-
GetLabel
–Get the label
-
GetLengthFactor
–Get the length factor
-
GetPlacementMatrix
–Get the placement matrix of the first bar
-
GetPositionNumber
–Get the position number
-
GetRotationAngle
–Get the rotation angle
-
GetRotationAxis
–Get the rotation axis
-
GetStartPoint
–Get start point of the placement at the placement line
-
IsPlacePerLinearMeter
–Get the place per linear meter state
-
IsPolygonalPlacement
–Get the polygonal placement state
-
IsRotationalPlacement
–Get the rotational placement state
-
Move
–Move the placement
-
SetBarCount
–Set the bar count
-
SetBendingShape
–Set the reinforcement shape
-
SetBendingShapeMatrix
–Set the bending shape matrix
-
SetCommonProperties
–Set the common properties
-
SetDistanceVector
–Set the distance vector
-
SetEndBendingShape
–Set the reinforcement shape at the end
-
SetLabel
–Set the label
-
SetLengthFactor
–Set the length factor
-
SetPlacePerLinearMeter
–Set the place per linear meter state
-
SetPositionNumber
–Set the position number
-
SetRotationAngle
–Set the rotation angle
-
SetRotationAxis
–Set the rotation axis
-
SetRotationalPlacement
–Set the rotational placement state
-
Transform
–Transform the placement
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
BarCount
(int
) –Get the bar count
-
BendingShape
(BendingShape
) –Get the shape polyline
-
BendingShapeMatrix
(Matrix3D
) –Get the bending shape matrix
-
CommonProperties
(CommonProperties
) –Get the common properties
-
DistanceVector
(Vector3D
) –Get the distance vector
-
EndBendingShape
(BendingShape
) –Get the shape polyline at the end of a polygonal placement
-
LengthFactor
(float
) –Get the length factor
-
PlacePerLinearMeter
(bool
) –Get the place per linear meter state
-
PositionNumber
(int
) –Get the position number
-
RotationAngle
(Angle
) –Get the rotation angle
-
RotationAxis
(Line3D
) –Get the rotation axis
-
RotationalPlacement
(bool
) –Get the rotational placement state
EndBendingShape
property
writable
EndBendingShape: BendingShape
Get the shape polyline at the end of a polygonal placement
PlacePerLinearMeter
property
writable
Get the place per linear meter state
GetBendingShape
GetBendingShape() -> BendingShape
GetBendingShapeMatrix
GetBendingShapeMatrix() -> Matrix3D
GetCommonProperties
GetCommonProperties() -> CommonProperties
GetDistanceVector
GetDistanceVector() -> Vector3D
GetEndBendingShape
GetEndBendingShape() -> BendingShape
GetEndPoint
GetEndPoint() -> Point3D
Get the end point of the placement at the placement line
Returns:
-
Point3D
–End point of the placement at the placement line
GetPlacementMatrix
GetPlacementMatrix() -> Matrix3D
GetStartPoint
GetStartPoint() -> Point3D
Get start point of the placement at the placement line
Returns:
-
Point3D
–Start point of the placement at the placement line
IsPlacePerLinearMeter
Get the place per linear meter state
Returns:
-
bool
–Place per linear meter: true/false
IsPolygonalPlacement
Get the polygonal placement state
Returns:
-
bool
–Polygonal placement: true/false
IsRotationalPlacement
Get the rotational placement state
Returns:
-
bool
–Rotational placement: true/false
SetBendingShape
SetBendingShape(shape: BendingShape)
SetBendingShapeMatrix
SetBendingShapeMatrix(bendingShapeMat: Matrix3D)
SetCommonProperties
SetCommonProperties(commonProp: CommonProperties)
SetDistanceVector
SetDistanceVector(distVec: Vector3D)
SetEndBendingShape
SetEndBendingShape(shape: BendingShape)
SetLabel
SetLabel(label: ReinforcementLabel, labelAssocView: AssocViewElementAdapter)
Set the label
Parameters:
-
label
(ReinforcementLabel
) –Label
-
labelAssocView
(AssocViewElementAdapter
) –Associative view for the label
SetLengthFactor
Set the length factor
Parameters:
-
lengthFactor
(float
) –Length factor
SetPlacePerLinearMeter
Set the place per linear meter state
Parameters:
-
bPlacePerLinearMeter
(bool
) –Place per linear meter: true/false
SetPositionNumber
Set the position number
Parameters:
-
positionNumber
(int
) –Position number
SetRotationAngle
Set the rotation angle
Parameters:
-
rotationAngle
(float
) –Rotation angle
SetRotationAxis
SetRotationAxis(rotationAxis: Line3D)
SetRotationalPlacement
Set the rotational placement state
Parameters:
-
bRotationalPlacement
(bool
) –Rotational placement state
Transform
Transform(transMat: Matrix3D)
__init__
overloaded
Initialize
__init__(placement: BarPlacement)
__init__(
positionNumber: int,
barCount: int,
distVec: Vector3D,
startPnt: Point3D,
endPnt: Point3D,
bendingShape: BendingShape,
)
Constructor
Parameters:
-
positionNumber
(int
) –Position number
-
barCount
(int
) –Bar count
-
distVec
(Vector3D
) –Distance vector
-
startPnt
(Point3D
) –Start point of the placement at the placement line
-
endPnt
(Point3D
) –End point of the placement at the placement line
-
bendingShape
(BendingShape
) –Bending shape
__init__(
positionNumber: int,
barCount: int,
startBendingShape: BendingShape,
endBendingShape: BendingShape,
)
Constructor
Parameters:
-
positionNumber
(int
) –Position number
-
barCount
(int
) –Bar count
-
startBendingShape
(BendingShape
) –Start shape of the polygonal placement
-
endBendingShape
(BendingShape
) –End shape of the polygonal placement
__init__(
positionNumber: int,
barCount: int,
rotationAxis: Line3D,
rotationAngle: Angle,
bendingShape: BendingShape,
)
Constructor for the rotational placement
Parameters:
-
positionNumber
(int
) –Position number
-
barCount
(int
) –Bar count
-
rotationAxis
(Line3D
) –Rotation point
-
rotationAngle
(Angle
) –Rotation angle
-
bendingShape
(BendingShape
) –Bending shape